LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Can't keep dual displays active. CentOS 5.8 Nvidia driver (http://www.linuxquestions.org/questions/showthread.php?t=4175434999)

wigglytoes 10-31-2012 11:21 PM

Can't keep dual displays active. CentOS 5.8 Nvidia driver
 
I'm trying to set up two monitors on a CentOS 5.8 box.
I'm using a Nvidia GeForce 9800 GT graphics card
I have two Acer G2267HQL monitors. (Just a couple basic Wide LCDs)
I've downloaded and installed the latest NVIDIA driver. 304.60
My 5.8 version is completely up to date.
When I YUM, I also go to ELEP and RpmForge.


I've spent all day on this problem. So far.
This morning I tried and tried to get the /etc/X11/xorg.conf file just right.
(not too soft, not too hard. Not too hot, not too cold.)
I even had example xorg.conf files from friends, from working Linux Redhat 5.8 dual monitor machines. Didn't seem to help.

At one point I discovered the nvidia-settings GUI tool. (I appreciate the hundreds of man-hours that went into the README file, but one screen capture of the real GUI, would have saved me many many hours)

Here's the thing.
Using the /usr/bin/nvidia-settings GUI, I CAN get both monitors working as one spanned display. I even have saved a new xorg.conf file while they are working correctly. I've even done that after deleting the current xorg.conf file. (So there is no xorg.conf file in /etc/X11)
Yet. If I go to Init 3 and back to Init 5, or logout and back in, or reboot, or restart the Xserver. I lose that 2nd monitor. At which point I can go into nvidia-settings and fix it again. It just won't stay that way.

A clue to what is going on is that, I believe that I have a good xorg.conf file. Because when I log in as ROOT, I get two monitors working with a spanned display. It comes up that way.
So it works if I log in as ROOT, but not if I log in as this lowly user.

Can anyone point me to the file permission, or lock file, or whatever could be my problem?

Thanks

Wiggly Toes

wigglytoes 11-07-2012 09:41 AM

And the answer is.... (From Nvidia support)

in the xorg.file (as superuser)
change
Option "Xinerama 0"
to
Option "Xinerama 1"

Which has the added benefit of having the taskbar be extended across both monitors


All times are GMT -5. The time now is 09:55 PM.