-   Linux - Hardware (
-   -   Cant install USB Flash Drive Kingston DTI/1 (

hemanth_ap 05-01-2006 06:28 AM

Cant install USB Flash Drive Kingston DTI/1
I could not use my Kingston DataTraveler 2.0 1GB. I'm new to Linux.
I have created a directory for Data traveler /media/flash
and added line /dev/sda1 /mnt/flash vfat user,noauto,umask=0 0 0 in fstab
tried to mount but it gives error
'mount: special device /dev/sda1 does not exist'
I had also tried loading 'modprobe usb-storage' then mounting Flash Drive

Linux Version:
# more /proc/version
Linux version 2.6.9-5.0.3.ELNextag_Dev (root@localhost.localdomain) (gcc version
3.4.3 20041212 (Red Hat 3.4.3-9.EL4)) #2 Mon Apr 11 11:54:04 IST 2005

# /proc/bus/usb/devices
T: Bus=01 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0930 ProdID=653d Rev= 1.00
S: Manufacturer=Kingston
S: Product=DataTraveler 2.0
S: SerialNumber=0603110357402
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us
E: Ad=83(I) Atr=03(Int.) MxPS= 8 Ivl=64ms

# lsmod | grep -i usb
usb_storage 30728 0
scsi_mod 59528 1 usb_storage

Somebody please help me
- Hem

David the H. 05-01-2006 08:30 AM

First of all, I suggest you always make sure the device is mountable on the command line before you go adding a line to fstab. You don't want to go mucking about with an important system file until you know what you're going to change.

One thing I can suggest is to try to mount /dev/sda instead of /dev/sda1. The 'sda' is the drive itself, and the '1' at the end points to a single partition on the drive. But fat formatted removable drives do not always have separate partitions; the whole drive can be used on its own. You often see this with flash drives and cards, .mp3 players, and any device that has flash memory really.

As root, try 'mount -t vfat /dev/sda /mnt/flash'. If it mounts successfully, then you can change your fstab.

Aand don't forget to always unmount the flash drive before you remove it.

hemanth_ap 05-03-2006 02:15 AM

Plugged the Flash Drive. Then Started the Machine.
logged as root. tried to mount the Flash Drive but it gives error message
"mount: special device /dev/sda does not exist"
tried 'modprobe usb-storage' then mount. Still giving same error.

David the H. 05-03-2006 03:01 PM

Ok, try this. First, you need to have the sg3-utils installed. You don't mention which distro you're using, so you'll have to find out how to install it yourself.

Then you can use the command sg_scan -i to find the scsi device number of your device, probably sg0, but if you have more than one scsi/usb device plugged in it may be something else. Then, run sg_map to find out what the actual mount point will be. sg0 will probably map to sda, sg1 to sdb, etc.

Finally, once you know all that, you can mount the device using that mount point. Be sure to try both sd* and sd*1.

If it still doesn't work, then you might have something wrong with your usb setup.

I got it all from this page:

All times are GMT -5. The time now is 10:30 PM.