-   Linux - Hardware (
-   -   Can't get sound driver installed (

GrdLock 05-15-2004 09:27 PM

Can't get sound driver installed
I have a Creative Audigy LS soundcard, which means I can't use the basic drivers from

Problem is, I have one of those pesky onboard sound controllers as well, a C Media something or other, which Mandrake 10.0's installation recognized and installed a driver for. I'm a linux :newbie: and have no clue how to get rid of that so that I can install drivers for my Audigy LS, the ones I found being from

In the Mandrake Control Center's Hardware section, I can't do anything except assign a new driver to the C Media card... I can't do anything with the Creative card, which of course it sees as an unknown sound device.

Would someone give me some help here? I tried downloading the OSS drivers from their web page and installing them but it tells me another sound driver is loaded, blah blah, it can't install, and gives me a bunch of stuff to do to fix it. I tried everything it said and nothing worked, the files it said don't even exist, or some other problem.


Output of lspci:
00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:09.0 Multimedia audio controller: Creative Labs: Unknown device 0007
00:09.1 Input device controller: Creative Labs: Unknown device 7005

2.6.3-7mdk (Mandrake 10.0 Community)

Xerop 05-15-2004 10:19 PM

Ok to do that I would disable your onboard sound by going into the bios. Probably by hitting del or F1 or even F10 at startup. There one of the menus will contain something about the card, diable it then try to see what you can do. This will prevent conflicts of the two sounds. After finishing all that try installing the drivers for the sound blaster. I have the same problem (different sound cards though) although I am not really worried about that, I am more interested to get 3D acceleration on my radeon 9800 pro.

tyme 06-04-2004 02:38 PM

did you ever get the audigy LS working? I'm trying to help someone here set it up, but I keep reading references to an proprietery OSS driver, but I can't seem to find it :/

thanks for you help!

All times are GMT -5. The time now is 06:37 AM.