-   Linux - Hardware (
-   -   Can't get CD Drive to read discs anymore (

M4A1Carbine 08-17-2003 10:30 PM

Can't get CD Drive to read discs anymore
Literally 3 seconds ago I was browsing through files on one of my many CD's and got the files I wanted and took out the disc. I then put in another one and when I go to /mnt/cdrom and pwd , then ls nothing shows up.

I know these discs have info on them! I can access them in Windows. If anyone knows how to get my drive to read CD's please tell me!

The drive is a Mitsumi CR-4804TE. (Able to burn and read discs, just not now for some odd reason) I'm using Mandrake 9.0

leonscape 08-17-2003 10:39 PM

Did you unmount and remount the drive between swapping disk?

Have you tried mounting them manually?

M4A1Carbine 08-17-2003 10:40 PM

I Don't recall doing anything to them. If I Need to re-mount it manually, how would I do that? (I'm still a bit noobish at that) If it isn't mounted, why would /mnt/cdrom show up?

leonscape 08-17-2003 10:46 PM

/mnt/cdrom is just a directory on your HD.

When you mount a drive to it what your doing is making the CD apart of your filesystem so /mnt/cdrom points to the drive.

as for unmounting if your using Gnome or KDE it should be under the right click menu for the drive (If its an icon on your desktop).

Usually if you double click the icon on your desktop it gets mounted automatically by the GUI, but they don't usually unmount.

To do this manually get a console up and type:
umount /mnt/cdrom

To mount its:
mount /mnt/cdrom

M4A1Carbine 08-17-2003 10:50 PM

THanks it worked..I guess my little malacious brother unmounted it.. still trying to figure out how he guess the root password =\

michaelk 08-17-2003 10:55 PM

Mandrake installs supermount which lets you access removable media without using the mount / umount commands. Supermount does have its problems.

Did you exit the file browser or change to some other directory or close any app that was accessing the CD before removing it from the drive.

M4A1Carbine 08-17-2003 10:56 PM

Actually I did michael..I guess I shouldn't have done that :(
Instead of spamming the boards with easily answerable questions I figured I'd ask in my already existant thread:

How do you run a .py file through the console?

michaelk 08-17-2003 11:17 PM

You will find that your /etc/fstab entry for the cdrom has the user option which allows non-root users to mount / umount the cdrom drive.

.py are python scripts. Assuming python is installed on your system and the script is an executable file. If you in the directory where the file is located.


leonscape 08-17-2003 11:18 PM


or python

Depending on the file.

All times are GMT -5. The time now is 11:22 PM.