-   Linux - Hardware (
-   -   can't find my mouse, I forget what to do (

kryptobs2000 07-29-2006 01:22 AM

can't find my mouse, I forget what to do
I have a usb mouse using slackware 10.2. If I leave it the way it is setup by default once I startx my mouse nor my keyboard work. The reason is because it's using something thats not my mouse or something stupid I'm not sure.

I had this same problem before, I just had to point it in the right direction to where my mouse is in xorg.conf, but I can't figure out where it is. I'm using the imps/2 drive, and I've tried:


maybe a few more, I'm pretty sure it was /dev/input/mouse0 or /dev/input/mice before. Could there be any other reason it's not finding the mouse, maybe a driver is not loaded or something, lsmod only shows 2 things, I forget what they are but neither is related to the mouse. How can I find where my mouse is at. I noticed when booting a knoppix live cd, and gentoo live cd(which I am currently typing this on) it finds my mouse at /dev/input/mice

Old_Fogie 07-29-2006 01:55 AM

yeah it's /dev/mouse

just run pkgtool mouse setup to tell slackware what to do again if your using the stock 2.4.31 kernel.

otherwise run pkgtool then xorgconfig or xorgsetup whatever you prefer

kryptobs2000 07-29-2006 07:23 AM

thats the problem /dev/mouse is linked to something that is not my mouse, so when I startx it'll work, but I can't use my mouse or keyboard then, if I choose any of the other options I've tried so far I can't start x it just spits out the no such device.

All times are GMT -5. The time now is 03:17 PM.