-   Linux - Hardware (
-   -   Can't find ATI video drivers package (Fedora 10 64, HD 4850)/ sound card drivers too (

mothergoose729 01-17-2009 03:47 PM

Can't find ATI video drivers package (Fedora 10 64, HD 4850)/ sound card drivers too
I can't seem to find the video drivers for my graphics card. I know ATI doesn't have the best linux support, but I have heard that the akmod-fglrx package will give me enough support to watch DVD movies and enable some screen effects without that white screen.

Also, I have a very expensive Auzentech X-FI prelude I would like to be able to use but I can't find a way to enable it. I magnaged to get my onboard to work but that is as far as I have gotten. Help with that would be appreciated.

jhwilliams 01-17-2009 06:26 PM

wrt ati card: may help. make sure you that you first add the necessary repos that page talks about (before the section on ati.) Incidentally, I generally found that stuff off the ati site was fairly worthless, but it *has* been many years since I had the misfortune of using ati on linux (maybe things have changed).

mothergoose729 01-18-2009 10:48 AM

ok I went to ATI's webiste and downloaded their Linux driver. I made sure that all the packages it mentioned were installed, but and in the instructions it asks me to do the following to start the installation automatically:

nstall Driver Option
The Install Driver option provides two driver installation options. The Automatic
option installs all driver components, and the Custom option allows for the selec-
tion of driver components to be installed.
ATI CatalystTM Linux Installer Note 3
Automatic Driver Installation Option
To install the ATI Proprietary Linux driver using the Automatic option, follow
these steps:
1 Launch the Terminal Application/Window and navigate to the ATI Propri-
etary Linux driver download.
2 Enter the command sh ./ to launch the
ATI Proprietary Linux driver installer.

I don't know how to "navigate" to anything in the terminal and I am confused. Right now I have the linux driver package in temp folder entitled "". When I open up the package via double click there is one file, 9.1mb in size (yet the whole package is 77mb?) and it is called What do I do from here?


Ialso, I have done some research on my sound card, and been told that creative has some good linux drivers. This person told me that a Creative X-Fi extreme gamer driver might work with my card. Here are the two linked side by side:

What do you guys think? Where would be a good place to find these drivers?

Shadow_7 01-18-2009 12:15 PM

navigation is easy. tab or alt+tab to jump to the next or previous item. space or enter to select. Cursor keys sometimes affect it too. Same as it is in windows, or web browsers or pretty much any applications.

As far as the ati drivers. Run them, then enter x5, down arrow, space, enter x2 (or x3) and you're done. Unless you want a distro specific version (which may or many not work, but is much easier to UNinstall, when it does work). Just be wary of sound card conflicts since the newer video cards have sound cards in them (HDMI / hda-intel). This tends to lock up my X session at startup since my motherboards nVidia sound/video card shares the same sound card driver as my ATI graphics card. Technically visiontek HD 4550. But visiontek doesn't have linux drivers.

mothergoose729 01-18-2009 02:01 PM

Ok I think there is still something that I am not understanding. I selected the file and then typed sh ./ in the window, and nothing happend. I tried right clicking and pressing "autorun prompt" and then resulted in nothing as well. I ran the terminal, atl-tabbed my way to the download file, then alt-tabed back to the terminal and typed sh ./ as a root command, and it told me that:

sh :./ no such file or directory

I am at a loss... I hate being so hopelessly noobish.

Shadow_7 01-18-2009 07:47 PM

# chmod +x ati-driver-*

It's not executable by default, since you downloaded it. Instead of copied it from some other filesystem where it was executable.

Might need sudo for that one in ubuntu. As you've got to do it as root.

mothergoose729 01-18-2009 11:27 PM

# chmod +x ati-driver-*

So I run this as a root command in the terminal? Or do I select it and type it in the window?

I am really sorry if all these questions are so basic. Have had linux for just short of three days now so I am trying hard to figure this out. Seems like all the information I find is distro specific, a solution not and explanation, and constantly changing with every new update...

Shadow_7 01-19-2009 08:38 AM

from an xterm, or from the console after you login.

$ sudo chmod +x ati-driver-*

$ sudo sh ati-driver-*

replace * with the actual remaining half of the filename. <tab> will likely do this for you. AKA tab completion.

You might also check out the (or whatever it's called). You're not likely to be the only one with this issue / question. I like ubuntu in that it's more up to date with modern processors. But I don't like that it tries to restrict the use of root altogether and only allows you to do most root-ish things from sudo.

mothergoose729 01-19-2009 11:35 AM

I am running Fedora 10 86x_64 though. I check my software package and I have sudo installed. Is this pretty much the same as super user? Or is this accessed differently?

I entered my terminal under super user mode and typed in those pieces of code. It asked for my sudo password, which I assumed to be the same as my root password? I then entered it in and it told me that "we trust you have recieved the usual lecture from the administration system manager...". After that it said "(myusername)is not in the sudeors file. This incident will be reported". I typed in the second bit of code, it asked for my sudo password, and then nothing happened.

What am I doing wrong?

Shadow_7 01-19-2009 02:08 PM

Sudo is just a way to give a common user root like abilities. If you can su to root, then by all means go that route. Far fewer hoops to jump through. Otherwise it's like Vista where you have to run as administrator, otherwise you end up installing your device driver half a dozen times before it actually installs. IF it installs.

When I use # I mean as root. When I use $ I mean as user.

All times are GMT -5. The time now is 09:11 PM.