LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Cant copy files to a fat partition i mount as RW? (https://www.linuxquestions.org/questions/linux-hardware-18/cant-copy-files-to-a-fat-partition-i-mount-as-rw-158144/)

FocusedWolf 03-15-2004 07:09 PM

Cant copy files to a fat partition i mount as RW?
 
Hi, this is weird...this worked before...but i wanted to try a beta fedora build, and when i formated that off and reinstalled my core 1 one...and set it up the exactly the way it was when this sorta thing worked (i,e, i could copy files to this partition before)...that it didnt work

this is how my /etc/fstab line goes

/dev/hda6 /mnt/Linux-To-Windows vfat users,owner,rw,umask=000 0 0

is their something i forgot to do?

jailbait 03-15-2004 07:19 PM

"Hi, this is weird...this worked before...but i wanted to try a beta fedora build, and when i formated that off and reinstalled my core 1 one...and set it up the exactly the way it was when this sorta thing worked (i,e, i could copy files to this partition before)...that it didnt work"

What command are you using to do the copy? What error message are you getting?

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

FocusedWolf 03-15-2004 09:07 PM

Its saying its read only, but it sholdnt be...even tried with root account but no dice.

"Error While copying to "/mnt/Linux-To-Window".
The destination disk is read-only."

i wasnt using a command, just opening the icon for the drive on my desktop and dragging to that folder/directory a file.

jailbait 03-16-2004 11:05 AM

'"Error While copying to "/mnt/Linux-To-Window".
The destination disk is read-only."'

Take a look at the permissions for /mnt/Linux-To-Windows. Try setting them to 777.

Also look at the line in /etc/fstab for /Linux-To-Windows and make sure that it is mounted with permissions for user access.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

FocusedWolf 03-17-2004 03:49 PM

hmm how do you do the permission thing?

jailbait 03-17-2004 05:57 PM

"hmm how do you do the permission thing?"

Log in as root. Linux will not let you change permissions on a mount point. So first umount the partition:
umount /mnt/Linux-To-Window

Use the chmod command (see: man chmod). If you want to change the permissions to 777 the command is:
chmod 777 /mnt/Linux-To-Window

Then reboot and you should be OK, assuming that /etc/fstab is set up to allow users to use /mnt/Linux-To-Window.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

FocusedWolf 03-18-2004 05:43 PM

TY! Worked perfectly :)


All times are GMT -5. The time now is 04:35 AM.