-   Linux - Hardware (
-   -   Canon Pixma MP250 - Slackware 13 it doesn't print (

xcristi 04-29-2010 04:09 AM

Canon Pixma MP250 - Slackware 13 it doesn't print
Hello folks,

Trying to make a Canon Pixma 3-in-1 MP250 to work with my Slackware.
I've took the drivers from the canon website (they have .deb, .rpm and sources there) and compile. Basically I followed the instructions from INSTALL files in each subdirectory (backend,cngpij, etc).

Then I upgraded also CUPS to 1.4.3.

Installing the printer in CUPS, I end up with:


Description:        Canon MP250 series
Driver:        Canon MP250 series Ver.3.20 (color)
Connection:        cnijusb:/dev/usb/lp0
Defaults:        job-sheets=none, none media=iso_a4_210x297mm

It seems ok. But when I send a test page (or any other kind) to printer, it shows some activity on the led display, cups reports the job as completed but nothing happens!

As an extra, I tried to convert .deb packages to .tgz and install from them. The same result, except now the scangear utility is working (so scanning is ok).

How can I find what's missing from here? Maybe it's a bug with cups/drivers or something is missing from configuration?

p.s. On other machine I have an Xubuntu (Karmic Koala). Installed there from .deb packages and the printer works as expected.

allend 04-29-2010 10:11 AM

You may find this thread useful.

xcristi 04-30-2010 03:45 AM

I tried removing usblp and also downgrading the cups to 1.3.X series. I got the same result: jobs are shown as completed but nothing prints actually.

I gave up for now and use a xubuntu for printing purposes. Maybe the next version of slackware will fix somehow the issue.

piootr 08-24-2011 08:50 AM

MP250 under slackware 13.37 works for me

MP250 works on slackware 13.37, cups 1.4.3 and IJ Printer Driver Ver. 3.40 ( for me

I've also followed the instructions in each subdirectory (libs,backend,backendnet,cngpij,cngpijmon,cnijfilter,lgmon,ppd,printui,pstocanonij) using --prefix=/usr --program-suffix=mp250 --enable-progpath=/usr;

then I copied *.so from 356/libs_bin32/ to /usr/lib and made
symbolic links according to:
and copied also 356/database to /usr/lib/bjlib

at the end I ran ldconfig, restarted cups, and added new printer

All times are GMT -5. The time now is 06:55 PM.