-   Linux - Hardware (
-   -   Canon PIXMA iP3600 HOWTO (

w1k0 04-24-2009 01:12 PM

Canon PIXMA iP3600 HOWTO
I managed to install the above printer in Slackware Linux. I describe the entire process to help the other users.

1. I got RPM Linux Printer Driver (3.0) from (file iP3600_RPM_printer.tar).

2. I unpacked TAR archive and – because I use Slackware – I converted both RPM files to TGZs with rpm2tgz and then installed them with installpkg.

3. Then I ran ldconfig followed by /etc/rc.d/rc.cups start (the last file should be executable).

4. After plugging printer I tested it with two commands:

# lpinfo -v

network socket
network beh
direct usb://Canon/iP3600%20series
direct hpfax
direct hp
network http
network ipp
network lpd
direct scsi
direct cnijusb:/dev/usb/lp0
network smb

# lsusb

Bus 005 Device 002: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 04a9:10ca Canon, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

5. Next I opened CUPS home page, added the printer using Administration | Find New Printers | Add This Printer, configured it with Printers | Set Printer Options (as root), and started with Printers | Start Printer (as root).

6. Finally I tested printer with Printers | Print Test Page.

It works!


I tested printing pictures from within GIMP after selecting printer and paper size 4x6" 10x15cm (borderless). The colors are perfect (nor better, nor worse, but slightly different than printed from Windows).


After setting CUPS' Printers | Set As Default option I managed to print pure text file using a2ps. I even didn't have to set custom margins in /etc/a2ps-site.cfg. The result was perfect out of the box.


That printer uses by default UTF-8 encoding so it's possible to print plain text files in different languages using lpr command after converting codepage to UTF-8.


I'm still not able to run ``Canon Status Monitor'' to see messages about printer status and ink cartridges. The program displays message ``Spooler error''.

malekmustaq 05-29-2009 10:05 AM


Very useful.

I have also tried this in pixma 1300 over Slackware 12.2 it worked.


cwellings 10-02-2009 10:52 PM

thank you for this helpful information

i mannaged to get this same method to work for the pixma ip4600 series

Katarien 11-19-2011 12:10 PM

Thanks, it worked for a MP550 to!

w1k0 11-20-2011 09:39 AM

I'm glad my HOWTO works not only with iP series but also with MP series.

Enzo_Italy 12-16-2011 01:16 PM

I'm using Slackware 12.2, and it works!
But, if I try to print using remote CUPS server, printer is seen & configurated but don't print anyway! Isn't bad settings in cups or in net configuration because other printer (HP photosmart) print by remote instead. So i think driver writter by Canon is buggy.
I tried also to install this printer in Slackware 13.37, using drivers by CUPS 1.4.6 but printer don't print test page!

w1k0 12-17-2011 01:43 AM

I gave my Canon ink printer to my friend and I bought Brother laser printer. I used my ink printer mostly to print black text on white paper and I hated that printer because I was still forced to buy new color ink cartridges to print in black. Monochrome laser printer is less universal than color ink printer but doesn’t cause my frustration.

As a result I can’t help you. I’m sorry. Maybe someone else will find the solution of your problems. It’s good idea to start a new thread if you expect some helpful feedback.

Enzo_Italy 12-17-2011 02:37 AM

Thanks for your reply. I concorde with you about laser vs inkjet performances.
However I esperienced similar troubles, printing from remote, also with an EPSON Stylus Photo 900, on same installation.
Where, before, was installed an EPSON Stylus Color 740, working from remote without problems.
And, before of 740, an Stylus Color 400 worked well from remote too.
So, perhaps some cups drivers have this problem?
(I'm referring at CUPS supplied with Slackware 12.2, with current CUPS supplied in Slackware 13.37 actually I haven't able to print nothing, because I installed Slack13.37 some days ago!)
Best regards, Enzo.

Katarien 12-17-2011 02:48 AM

I had some problems first to.
After a restart without the printer plugged in it worked fine.
So first installing the drivers and then plug in the printer for me was essential, like w1k0 says in point 4.

Enzo_Italy 12-17-2011 03:52 AM


So first installing the drivers and then plug in the printer for me was essential, like w1k0 says in point 4.
Thanks a lot! I'll try it!

Enzo_Italy 01-05-2012 11:35 AM

I tried it, but same results.
Seems as a permission problem, but CUPS permissions are ok (otherwise the other printers would not work).
In my opinion Canon driver is buggy.
In my opinion Canon should continue to produce only poor cameras, instead of jumping into the printer market.
But, in these days, all printer makers are more committed to prevent the charging of the cartridges that produce reliable printers!

Enzo_Italy 02-24-2012 05:52 AM

I contacted Italian Canon, and explained my problem, hoping that they may be solve driver problem.
They answered me that this printer can print only in local USB mode. They suggest me to buy a printer server from Silex Technology!!
In my opinion I do not think they understood (and probably will never understand) the problem. They have not idea what is CUPS or a Linux print server, of course.
So I suggested to them to review their trade policies, and perhaps to return to their former job as a producer of cheap cameras.
No reply (obviously) from Canon...

Enzo_Italy 08-23-2012 05:30 AM

Canon don't support linux : I don't support canon
Still at this time, this printer is unable to remote printing!
Problem is in drivers, and Cannon don't care (don't know ?) to fix them.
I blacklisted Canon from my hardware suppliers, because they love only Microsoft, so please Canon sell your bad product to Mr. Gates & Mr. Ballmer, but you don't see 1 cent from me anymore! ! ! :-(

All times are GMT -5. The time now is 06:42 PM.