LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-02-2005, 10:16 AM   #1
dereut
LQ Newbie
 
Registered: Apr 2005
Posts: 23

Rep: Reputation: 0
Canon a300 view by gphoto2 but not as fs


hello all,

I have a FC3 system with usb1.1, a digital camera canon A300, and I am trying to install it as a masse storage system.

I have a very important mediacard full of photos but the file system in it is corrupted, I beleive only linux will let me access it.

the problem is that if I plug my camera on the usb plug, Gphoto2 detect the camera, import what can be import, but I cannot moun the camera.

dmesg only list (on the last line):
usb 1-1: new full speed USB device using uhci_hcd and address 1

there is no recognision of scsi device
usbcore is compile in the kernel
lsmod shows

ohci_hcd 24084 0
sg 34464 0
sd_mod 16384 0
usb_storage 62280 0
scsi_mod 122240 3 sg,sd_mod,usb_storage
vfat 12928 0
fat 39840 1 vfat
uhci_hcd 31896 0

more /proc/bus/usb/devices

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 17 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=32 #Cfgs= 1
P: Vendor=04a9 ProdID=3076 Rev= 0.01
S: Manufacturer=Canon Inc.
S: Product=Canon Digital Camera
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=06(still) Sub=01 Prot=01 Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=83(I) Atr=03(Int.) MxPS= 8 Ivl=96ms


sg_scan -i shows nothing, just a blank line

I know this camera was working as a mass storage when plug behind a MDK 9.2
I greate 'MAKEDEV sda' as there was none in /dev


help ???

thanks

reup
 
Old 04-10-2005, 09:12 PM   #2
funkydan2
Member
 
Registered: Mar 2004
Location: Brisbane, Australia
Distribution: VectorLinux; Ubuntu
Posts: 135

Rep: Reputation: 15
You'll have to tell the camera to work in 'USB Mass Storage' mode. So enter the setup section of the camera and see if that is possible.

If your camera can only work using its proprietary format, you're probably best finding a card reader for your memory card and trying that.

Daniel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gphoto2 can't detect canon powershot a95 $in Slackware 11 11-30-2005 05:58 AM
Canon Powershot sd500 with gphoto2 amenon Linux - Hardware 1 10-15-2005 11:49 AM
gphoto2 and Canon IXUS 500: permissions problem? tawalker Linux - Software 0 11-17-2004 04:16 PM
Can't access Canon digicam with gphoto2 Slacker0815 Slackware 9 08-27-2004 05:53 PM
Printing - Compaq A300 versaulis Linux - Software 0 10-10-2003 07:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration