-   Linux - Hardware (
-   -   Cannot start ubuntu (or other distros) after mother board replacement (

fotofill1969 02-22-2012 12:43 PM

Cannot start ubuntu (or other distros) after mother board replacement
My motherboard crapped out and I bought a refurbished one (same model number) on E-Bay and had it installed by a local technician. I have Ubuntu installed on the HD. When I start the laptop now it gives me the following:
error: unknown filesystem
grub rescue> _

If I try to reload a distro from an ISO image things start to go well but then I get:
(initramfs) stdin: i/o error
mount: mountiing /dev/loop0on //filesystem. squashfs failed: no such device cannot mount /dev/loop0 (cd rom/Kubuntu/casper/filesystem.squashfs) on //filesystem squashfs

I was able to load Mint in compatibility (text) mode but gui installs come back with the i/o error message.

Any ideas out there?

ButterflyMelissa 02-22-2012 01:36 PM


I have Ubuntu installed on the HD.
Is that the original install? You "just" replaced the board, but kept the rest. Is a load of (for example) Knoppix possible? That loads into a text-only menu, there you can use "graphical programs" and then select "lxde" - just to see what THAT'll do...

Unknown filesystem, that's weird. But feasable. Do realise that an installer scans the system in place at the time, if something changes, this could (IMHO) confuse things somewhat...

Just thinking out loud, dont kill me for it... :)


PTrenholme 02-22-2012 02:05 PM

loop devices are "mounted" by placing a small bit of code in memory and "pointing" it to the source data. Since you are reading from your CD, the "unknown file system" message may be telling you that your laptop memory has a problem. Can you boot to your BIOS and verify that your memory chip(s) was correctly installed on the new m/b? Or just run memchk from an installation disk. (It's possible, but somewhat unlikely, that the technician damaged your memory chip(s) whilst replacing the m/b.)

H_TeXMeX_H 02-22-2012 02:17 PM

I would check everything inside and make sure it was installed properly, all the cables and stuff. A live CD may help diagnose it like Thor_2.0 suggests, but you may have already tried it from what you said.

selfprogrammed 02-22-2012 05:00 PM

Your Linux description is a little confusing, and sounds unfamiliar.

New motherboard means the BIOS got replaced too and the BIOS flash too.
Check that the BIOS is setup correctly for that hard drive, and setup all the other BIOS settings to your preferences.

I would suspect the cable to the HD, or a bad HD controller, OR it may not be the same identical board.
Some replacement boards are not checked out as carefully as you would like, it may be bad, it may have been damaged in installation. The install is the most likely time for a board to be damaged. I ruined one drive and controller by plugging the cable in one pin off to the left. Dropped a tiny screwdriver on another motherboard and after that it could not recognize a full memory set. It could see the memory in any slot, but could not use all memory at once.

The tech who installed it should use a diagnostic disk to completely check HD operation.
An alternative is to use a bootable CD with a live self contained Linux.

Try fschk, e2fschk, fschk.ext2, fschk,ext3, fschk.cramfs or whichever matches your hard drive filesystem
>> fschk /dev/sda0
>> fschk /dev/sda1

Check that the drive can be read (this is non-destructive, just don't make the mistake of putting a -w or -f in there).
This takes a long time, but is though.
>> badblocks -n -v /dev/sda0

If the hard drive is readable, then likely the MBR got clobbered by the tech. Reinstall your boot program (GRUB) using the bootable CD.

Why would you be installing a new ISO image to a hard drive, if the existing hard drive was not replaced ??
The old partitions and filesystem should still exist there.

I am unfamiliar with this installation method, do not know squash, but does it not require partitioning the drive and formatting the drive partition first.
Are not ISO images usually written to a CDROM because they use a CDROM type filesystem.
Yes, you can test one using a loopback device, but there is a whole underlying partition and
filesystem that must exist and be working first.

fotofill1969 02-23-2012 10:03 AM

Thank you , selfprogrammed, for the very thorough reply and suggestions.
With the cryptic message:
error: unknown filesystem
grub rescue> _
I thought that I would try to re-install linux, repartition, etc. but I didn't get that far. The cd-rom drive is seen by the bios and mounts and begins the installation of (in this case I tried Kubuntu, and Mint consecutively) the OS but then I got the error message and a prompt. If I type "help" I get a series of possible commands that I can enter at the shell prompt. Since I don't know what's going on and I don't know what those programs will do, I came to the community.

I will certainly give your suggestions a try!

EDDY1 02-23-2012 11:54 AM

Check the bios to see that everything is recognized & just in case your technician entered the wrong values in bios select "Load Default Values"

cascade9 02-24-2012 03:56 AM


Originally Posted by fotofill1969 (Post 4609395)
My motherboard crapped out and I bought a refurbished one (same model number) on E-Bay and had it installed by a local technician.

Wouldnt be the 1st time that someone has some a faulty part on ebay. Or the 1st time that a techie hasnt checked the parts he/she has just installed, or not told the customer that the parts are dodgy if they do check...


Originally Posted by selfprogrammed (Post 4609585)
New motherboard means the BIOS got replaced too and the BIOS flash too.

Its not new. Even if it was RMAed, that doesnt mean its a 'new' board (as long as the board has been for sale a few months, its common to to get 'refurbished' boards). RMAing a board, no matter if you get anew board, or a refurbished one, doesnt mean you will get the newest BIOS either.

fotofill1969 03-03-2012 08:53 AM

This was a very interesting situation. I followed the advice given above and had success with some of the processes.
The fsck command found and corrected the errors on the hard disk.
badblocks ran for eight hours before I stopped it.
I changed several items in the bios
memchk did not find any problems
Reinstalling GRUB was unsuccessful
But I was able to re-install Ubuntu from an ISO disk. Since I was able to rebuild everything that I had on the disk with very little trouble I consider this a success.
Thank you!

All times are GMT -5. The time now is 12:43 PM.