LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-23-2007, 08:36 AM   #1
grabro
Member
 
Registered: Oct 2003
Location: Chester
Distribution: Mepis 6.0
Posts: 125

Rep: Reputation: 15
Cannot Start Scanner - Device busy


Hi

I have Mustek Scanexpress 1200 UB Plus scanner and my OS is Mepis 6.0. I finally managed to get Xsane and Kooka to load and recognise my scanner. I say recognise but they see it as Mustek Bearpaw 1200 CU scanner. Now don't mind what they call it unless this is the reason for my problem.

Neither Kooka or Xsane will scan and I get he fault "Cannot Start Scanner - Device busy". Now as far as I can determine from this cryptic message either the the software is seeing he scanner already on when it isn't or the it is seeing the usb port occupied by something else.

I've looked in all my log files to see if there are any clues to what is going on but no success.

Has anyone any idea what I must do to resolve his?

Thank

grabro

Last edited by grabro; 01-03-2009 at 09:34 AM.
 
Old 05-02-2007, 11:49 AM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Did you ever get this to work?
I got my Mustek 600 III ep working after a bunch of messing around, and during the process, I received a lot of the same message, and it was due to incorrectly specifying the scanner's device name when trying to access it. Instead of telling me 'device not found' or something useful like that, it told me 'Device Busy'.
By using the 'scanimage -L' command as root, and a few other things, I was finally able to specify the correct device. Now, the fastest way for me to scan a basic image is like:
Code:
scanimage > /path/to/saved/image/filename
and if you run this command as root at the command line, and it works, then all is likely set up just fine.
One thing I DID have to do, in order to use for example GIMP to scan images, was run GIMP as root, because by default the scanner device/device node is owned by root. Rather than change the permissions, I just made a desktop link like 'kdesu gimp-command' and problem solved. You may choose togo the permissions route.
And btw, GIMP has an awesome scanner interface which works 110% great with my scanner!
For more info on my exact course of action, search LQ for posts by me, containing the words 'mustek 600 scanner' and I'm sure you'll find it easily.
SV
 
Old 11-21-2007, 05:24 AM   #3
grabro
Member
 
Registered: Oct 2003
Location: Chester
Distribution: Mepis 6.0
Posts: 125

Original Poster
Rep: Reputation: 15
usb scanner - Device Busy

GrapefruiTgirl

Hi sorry for the delay in acknowledging your input but have been busy.

Have changed PC and upgraded OS to Mepis 6.5 but still the same problem with the scanner. I have of course been trying to resolve this as it is now the only problem I have on the PC. Incidentally this scanner worked fine when I had Suse as the OS.

I tried your advice but it did not work. I also had some other advice which I tried at the command line as user.

grabro@1[~]$ sane_debug_Mustek=255 scanimage -d gt68xx >image.pnm
scanimage: sane_start: Device busy

Now it takes about 60 seconds for it to tell me the "device Busy" so during this time I ran "dmesg | tail" in another terminal and this was the result.

[17191925.488000] ppdev0: registered pardevice
[17191925.508000] ppdev0: negotiated back to compatibility mode because user-space forgot
[17191925.508000] ppdev0: unregistered pardevice
[17193536.316000] ppdev0: registered pardevice
[17193536.316000] ppdev0: unregistered pardevice
[17193536.332000] ppdev0: registered pardevice
[17193536.332000] ppdev0: unregistered pardevice
[17193536.332000] ppdev0: registered pardevice
[17193536.356000] ppdev0: negotiated back to compatibility mode because user-space forgot
[17193536.356000] ppdev0: unregistered pardevice

Do You have any idea what this means? What on earth is "user-space forgot"!!

Thanks for your interest

grabro
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Scanner help.. failed to open device snapscan/dev/usb/scanner johnathan Linux - Hardware 2 10-12-2007 06:06 PM
/: Device busy? ginda Linux - Newbie 4 02-02-2005 04:29 PM
Device is busy anamika123 Linux - General 6 09-19-2004 11:58 AM
Device is Busy...??? GrumpyGnome Linux - Software 2 07-01-2004 11:43 AM
Device is busy juanb Linux - General 5 11-05-2003 07:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration