LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-15-2005, 11:31 AM   #1
kinlinux
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Rep: Reputation: 0
Question Cannot mount CD-ROM drive


Dear All,

I have successfully installed Red Hat Enterprise 3 on my computer via CD-ROM installation.

However, when the system started, I opened a new terminal window and typed "mount /dev/cdrom" to mount the CD-ROM drive but failed. The error message was as follows:
****
Mount: Wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
(could this be the IDE device where you in fact use ide-scsi so that sr0 or sda or so is needed?)
****

Then, I tried to type "mount /dev/cdrom /mnt/cdrom -t iso9660" but the same error message was displayed.

In the /etc/fstab, there is the following entry:
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

Later I tried to use the "Hardware Browser" tool provided in REHL 3 to display the CD-ROM information. The information is as follows:
****
Ricoh CD-R,RW MP7200A
Manufacturer: Ricoh
Driver: none or built-in
Device: /dev/scd0
****

Although my motherboard supports both IDE and SCSI devices, my CD-ROM drive is just an IDE Ricoh CD-ROM. I don't know why the "Hardware Browser" detects /dev/scd0. But anyway, I also tried to run "mount /dev/scd0" but it said "no medium found" this time.

Anyone knows how to fix the problem? Please help!!

Thanks a lot in advance.
Kin
 
Old 06-15-2005, 12:39 PM   #2
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
Well, if your cdrom is an entry in your /etc/fstab file (with /mnt/cdrom as the mount point), you should be able to type "mount /mnt/cdrom" as root (not "mount /dev/cdrom"). Mount in this format works with the mount point, not the device.
 
Old 06-16-2005, 08:43 AM   #3
kinlinux
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks. I also tried to type "mount /mnt/cdrom" before but it was still failed with the same error.
 
Old 06-16-2005, 08:46 AM   #4
franzfranz
Member
 
Registered: Mar 2004
Location: Indiana, US
Distribution: gentoo
Posts: 87

Rep: Reputation: 15
could you post your /etc/fstab? also, you could try mount -t auto /mnt/cdrom. Do you have a /mnt/cdrom folder?
 
Old 06-18-2005, 01:01 AM   #5
GingerMegs
LQ Newbie
 
Registered: Apr 2005
Location: Rockhampton, Queensland, Australia
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
mounting cdrom & floppy

Hello kinlinux and franzfranz,

I'm running Fedora Core 3 (FC3) and get the error message "cannot find /mnt/cdrom in fstab or mtab" . I'm informed that fstab-sync edits fstab, however whenever HAL daemon is started, it purges previous entries via fstab-sync.

Interestingly, I can open my home folder, click DEVICES, and see the cdrom and floppy iconned. Clicking on either device will display the contents. OK if I want to copy files to a floppy, however, burning to cdrom, and reading music etc from cdrom need the device to be mounted, adn that just ain't happenin'.

I have a /mnt folder, and when I list its contents I find it's empty.

Where do we start to fix all this please?

Cheers
GM
 
Old 06-18-2005, 02:20 AM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
A few misc comments: First, you must have a data CD inserted into the CD drive in order to mount it. You cannot mount an empty CD drive (since there's nothing for the system to actually mount), nor can you mount an audio CD (since audio CD's lack a valid filesystem). Additionally, it may be that if you're running a 2.4.x kernel, that you might need to manually load the ide-scsi module (via the modprobe command) if it's not already being loaded automatically. If you're seeing a reference to "/dev/scd0", then what I'd try is simply
Code:
mount /dev/scd0 /mnt/cdrom
which should do the trick. Note that the mountpoint (eg, /mnt/cdrom) must already exist in order for you to mount a device to it. Hope some of this is relevant, good luck with it -- J.W.
 
Old 06-18-2005, 02:47 AM   #7
GingerMegs
LQ Newbie
 
Registered: Apr 2005
Location: Rockhampton, Queensland, Australia
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
Dear J.W

that's just it ... the mountpoint [ /mnt/cdrom ] doesn't exist. I've discovered /media/cdrecorder, and /media/floppy.

In the properties window I adjusted the system to point to /media/floppy and it's happy.

Not so simple with a cd-burner.

My floppy is now happily reacting to a double-click, but dubclicking the cdrom icon keeps me gettig messages e.g. " according to mtab: /dev/hdd is already mounted on /media/cdrecorder"

Are we getting closer, do you think? Also are other FC3 users having the same problem?

Cheers, and many thanks for your help,
GMegs
Australia
 
Old 06-18-2005, 03:08 AM   #8
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Well, if you're getting an error saying it's already mounted on /media/cdrecorder, then you should be able to just go over to the /media/cdrecorder directory, and your data should be visible. (If you manually attempt to mount a device that's already mounted, you'll get the "already mounted" error.) Have you attempted that, and if so, what are the results? Unfortunately I don't use FC3 myself so I can't offer exact advice, but generally CD mounting problems are due to a few common issues (such as trying to mount it when it's empty or there's an audio CD inserted)

BTW, note that the /mnt/cdrom mountpoint I mentioned above was only an example, techincally you could mount the CD to any existing mountpoint. In order to keep things orderly though, I think it's best to mount things to a subdirectory within /mnt that corresponds to the device itself. In other words, I would mount the floppy to /mnt/floppy, the CD to /mnt/cdrom, etc. Alternatively, if your distro uses other mountpoints by default, such as /media/cdrom or /media/cdrecorder, then that's perfectly OK too, you would just need your mount command to match. -- J.W.
 
Old 06-19-2005, 02:07 AM   #9
GingerMegs
LQ Newbie
 
Registered: Apr 2005
Location: Rockhampton, Queensland, Australia
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
J.W. many thanks for that, however am still not getting anywhere.

The following lines are in my /etc/fstab file:

/dev/hdd /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,ro,exec,noauto,managed 0 0

/dev/fd0 /media/floppy auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,managed 0 0

Possibly they might give you a clue. Many thanks for your reply and your advice, it's greatly appreciated
GM
 
Old 06-19-2005, 02:27 AM   #10
GingerMegs
LQ Newbie
 
Registered: Apr 2005
Location: Rockhampton, Queensland, Australia
Distribution: Fedora Core 3
Posts: 13

Rep: Reputation: 0
Hello Moderator,

in a terminal, I've changed to the /media/cdrecorder directory containing a mandrake linux apps disc. When I ls /media/cdrecorder/mandrake I get the message that there is no such file or directory.

However, when I click on my desktop HOME icon, then DEVICES, I see an icon of a folder titled "Mandrake", which contains another folder "RPMs" which contains some 300 or so files

How is it that the [ ls ] command reveals the Mandrake folder name, but I can't change to it in the usual way?

Thanks,
GM
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount CD Rom drive during boot harisund Linux - Hardware 0 11-24-2005 04:32 PM
redhat 9 - CD-ROM drive won't mount: "Not a directory" zyzychyn Linux - Hardware 8 06-11-2004 11:33 AM
unable to mount cd rom drive m_boots Linux - Hardware 11 04-06-2004 10:00 PM
Can't mount cd-rom drive (not a valid block device) patrickdepingui Linux - Hardware 3 04-14-2003 11:39 AM
NEW CD-ROM drive, can't mount it!! DenShinobi Linux - Newbie 3 04-11-2002 06:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration