-   Linux - Hardware (
-   -   cannot mount 3TB FreeAgent GoFlex USB drive (

lizardofos 05-01-2012 09:24 AM

cannot mount 3TB FreeAgent GoFlex USB drive
This drive is new out of the box. When I connect it I get a lengthy error message which essentially says that the NTFS boot sector or partition table is corrupt. I'm using SuSE Linux Enterprise 11 with kernel. The drive is identified as /dev/sdc and the sdc1 partition exists. I attached the drive to a Windows XP machine and it mounted and was usable. I ran parted -> list devices and it shows up as:

/dev/sdc (3001GB)

The output of dmesg and lsusb are:

Lines from dmesg:

usb 1-4: USB disconnect, address 2
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: configuration #1 chosen from 1 choice
scsi6 : SCSI emulation for USB Mass Storage devices
usb 1-4: New USB device found, idVendor=0bc2, idProduct=50a5
usb 1-4: New USB device strings: Mfr=2, Product=3, SerialNumber=1
usb 1-4: Product: GoFlex Desk
usb 1-4: Manufacturer: Seagate
usb 1-4: SerialNumber: NA0LZX3N
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
scsi 6:0:0:0: Direct-Access Seagate GoFlex Desk 0D19 PQ: 0 ANSI: 5
sd 6:0:0:0: [sdc] 732566645 4096-byte hardware sectors: (3.00 TB/2.72 TiB)
sd 6:0:0:0: [sdc] Write Protect is off
sd 6:0:0:0: [sdc] Mode Sense: 4f 00 00 00
sd 6:0:0:0: [sdc] Assuming drive cache: write through
sd 6:0:0:0: [sdc] 732566645 4096-byte hardware sectors: (3.00 TB/2.72 TiB)
sd 6:0:0:0: [sdc] Write Protect is off
sd 6:0:0:0: [sdc] Mode Sense: 4f 00 00 00
sd 6:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1
sd 6:0:0:0: [sdc] Attached SCSI disk
sd 6:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete

# lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0bc2:50a5 Seagate RSS LLC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


MensaWater 05-01-2012 10:01 AM

Are you wanting to run it as NTFS so you can move between Linux and Windows or do you only intend to use on Linux?

When I researched a similar USB drive from Western Digital my notes indicate that I would have needed to download 3rd party Fuse ntfs-3g packages and use ntfs-3g as the type for mount on Linux to use NTFS.

However I didn't do that at all - I used fdisk to change the disk type to Linux then layed out an ext3 filesystem on it and was able to mount that way.

The risk we took is it was possible the manufacturer's firmware was tied to the NTFS and might have made the drive unusable. That didn't occur for the WD drive but it is a risk for your drive. You might want to see if anyone has successfully reformatted by doing a web search.

lizardofos 05-01-2012 10:55 AM

I plan to use it as a backup repository on this SuSE linux server. I am not married to the NTFS filesystem. I have searched the web and information is sketchy. I'm considering sending this drive back but would be really disappointed if I couldn't use a 3TB drive.

MensaWater 05-01-2012 12:12 PM

Since Linux discovered your drive my guess is that using fdisk to set partition type to Linux then formatting it with ext3 fielsystem as we did with ours would work but I can't guarantee it. In our case our plan was to try it and if it didn't work we'd set it back to NTFS and send it back as defective. Luckily we didn't have to do that. The web site for the drive mentioned Linux/UNIX but didn't say much.

My notes from when we bought it suggested that there was a Verbatim drive we identified at the time that listed Linux support. The WD drive didn't but did list MacOS which is why we felt it would likely work.

The specific WD drive we used is below - I can say with certainty that it worked on Linux after being reformatted with ext3.
WD (Western Digital) My Passport Essential SE 1 TB USB2.0/USB3.0 external drive.

I notice the web page for GoFlex lists both Windows and MacOS compatibility (but not other UNIX/Linux). This is about what I saw for the WD drive before I winged it.

Again you can try doing ntfs-3g but if this is not being shared between Windows and Linux I don't see any reason to keep an ntfs filesystem on it.

lizardofos 05-01-2012 02:22 PM

Thanks for your replies. I have been considering the same route you took - try Linux and then put NTFS back on and send it back if I have to. I notice that your drive is 1TB. I am replacing a dead 1TB FreeAgent Desktop drive which was working just fine. This leads me to wonder if there is some limit to how large an NTFS drive can be mounted under Linux. I haven't seen anything definitive.
Anyway, I'll give it a try and post back with my results.

jefro 05-01-2012 03:05 PM

I think I'd be tempted to take a very new live cd and boot to it. Then see how this drive works on it.

lizardofos 05-01-2012 03:58 PM

Are you talking about a parted live CD? If it does work, what would that tell me?

syg00 05-01-2012 06:45 PM

It'll tell you Linux can talk to the drive.
If that's a 3 Gig partition then you're talking a gpt formatted disk. fdisk won't talk to it, but it should warn you. Current parted should. Note I said current. SLES isn't exactly bleeding edge (although I haven't looked at SP2 yet).

k3lt01 05-01-2012 08:14 PM

There is an issue with newer drives, which I am pretty sure yours would be, and some older kernels. They can see the drive but not mount or write to it. If you tried with a 3.x kernel I think you may find things would work as you expected.

teckk 05-01-2012 08:19 PM

My 2 cents.

#parted /dev/sdc print
How are you trying to mount it?

#ntfs-3g /dev/sdc1 /mounting/point
Some reading for a 3TB disk

jefro 05-01-2012 08:39 PM

I would not use a parted cd. I'd use one of the mainstream live cd's such as Fedora, Ubuntu or another newish cd/dvd.

It would help diag the issue. If the thing fails and I'd agree that it almost has to be gpt then we are left with two parts. One is the usb and the other is the computer to check next. If it works then we can assume that your OS is the fault or some part/setting of.

lizardofos 05-02-2012 09:07 AM

2 Attachment(s)
Thanks for all the responses. This has been very educational. I booted from Gparted Live and Gparted sees 2 partitions, neither of them NTFS. When booted into SLES, there are no partitions,only /dev/sdc. I have attached two files showing this discrepancy. On the Live CD, ntfs-3g also complains that there is no valid NTFS partition.

One suggestion was to use a Live CD other than Gparted. I found one called Ubuntu Cloud Live. Would that be a good one to use or is there a better choice?

suicidaleggroll 05-02-2012 10:27 AM

FWIW - I just purchased two Seagate FreeAgent GoFlex 2TB drives about a week ago.

The partition information reported by fdisk was complete crap. Neither drive made sense, and the partitioning scheme on the two drives didn't even match each OTHER, much less anything rational. One drive reported having 255 heads, 63 sectors/track, and about 250,000 cylinders (don't remember the exact number), the other IDENTICAL drive reported having 1 head, 63 sectors/track, and about 60 million cylinders. Both drives appeared to have a single ~150MB FAT partition with nothing else.

After spending about 10 minutes wondering what in the world Seagate was trying to do with the drives, I just used fdisk to wipe the entire partition table, reset the heads/tracks to 255/63, and set up a new primary partition the full size with an ext3 filesystem on each drive. They now look rational, match each other exactly, and work great.

lizardofos 05-02-2012 02:15 PM

I booted Ubuntu 12.04 from CD. parted output looks pretty much the same except that sdc2 shows 73GB instead of 66GB. ntfs-3g fails with message that partition is not valid NTFS, which makes sense because parted sees it as linux-swap. For a sanity check, I put it back on a Windows system and it still shows up as 3.0GB NTFS in disk manager. It's also GPT Protected Mode (or something like that).

The fact that a single NTFS partition shows up as two partitions on Linux (1 as linux-swap and 1 as ext3) is quite puzzling to me. It appears that Linux (even with a newer kernel) has no idea what to do with a 3TB disk.

At this point it appears that I have to try to repartition and put an ext3 FS or give up and send it back. I was really hoping to be able to use a 3TB disk.

suicidaleggroll 05-02-2012 02:25 PM


Originally Posted by lizardofos (Post 4668760)
It appears that Linux (even with a newer kernel) has no idea what to do with a 3TB disk.

I'm about 99% sure it has to do with how Seagate set up the drive from the factory, not the fact that it's 3TB. If you read my post above, I had very similar issues with their 2TB model as well.

The same machine I used to reformat the 2TB drives also runs a 30TB RAID without issue. Linux is perfectly fine with big partitions and big filesystems.

All times are GMT -5. The time now is 02:44 PM.