-   Linux - Hardware (
-   -   Cannot get Linksys 300M USB Ethernet dongle working on Ubuntu 5.04 (

LinuxMike 06-20-2010 03:17 AM

Cannot get Linksys 300M USB Ethernet dongle working on Ubuntu 5.04
Tried configuring usbnet module but adapter is still not recognized on Ubuntu 5.05. Anyone every do this without compiling ASIX source?

yooy 06-20-2010 04:27 AM

strange a bit to me why using so old software..maybe updating can help

knudfl 06-20-2010 05:19 AM

Welcome to LQ.

Ubuntu 5.04 means 2005 - April , it is old as said by @yooy.

The ethernet adapter may work with a modern Linux ?


LinuxMike 06-20-2010 08:24 AM

Why using Ubuntu 5.04?
Works well on older laptop, that is why I am using it.... The adapter works fine with newer distros.

Drakeo 06-20-2010 10:16 AM


This is all about the kernel
The kernel has the job to handle the modules. Have fun building one.
Be careful the gcc has a lot to do with it. building modules with a kernel should be the same gcc as the kernel build.

LinuxMike 06-21-2010 12:25 AM

Yup DrakeO, thats what I concluded. Pull the source and compile against the 5.04 kernel. Compile the new driver into the old kernel Well, I was trying to avoid the interest of time.

Well, here is what I ended up doing which worked like a charm...simply 'upgrade' to Xubuntu 8.04 which I knew would recognize the 300M adapter. The lightweight X Windows in Xubuntu offsets the heavier Gnome in Ubuntu so performance runs reasonably well on my Toughbook like before and the usb adapter hotplugs just fine.

Lesson-learned: sometimes its just easier to upgrade!


All times are GMT -5. The time now is 07:11 AM.