Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 09-01-2003, 02:07 PM   #1
Senior Member
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Cannot enable dma on cdrw

my dad came over and i installed red hat 7.3 on his dell latitude c800 laptop. his laptop is about 6-7 months newer than mine. the problem i'm having is that enabling dma on his fixed dvdrom drive and the modular bay cdrw is failing. my laptop, dell inspiron 8100, has a fixed cdrw drive and modular bay dvdrom drive and dma enables fine for both of them. anyway, i was thinking that is because his modular bay cdrw is an atapi device, but his fixed dvdrom won't enable dma either and both of my devices enable dma fine. the only thing different on the install and setup that's different from mine is that he installed the red hat ntfs support patch rpm. any ideas? below is some hdparm info on my dad's modular bay cdrw.

[root@donslap ~]# hdparm -I /dev/hdc


ATAPI CD-ROM, with removable media
        Model Number:           TOSHIBA CD-RW/DVD-ROM SD-R2002
        Serial Number:
        Firmware Revision:      1E29
        Used: ATAPI for CD-ROMs, SFF-8020i, r2.5
        Supported: CD-ROM ATAPI-2
        DRQ response: 50us.
        Packet size: 12 bytes
        LBA, IORDY(can be disabled)
        Buffer size: 2048.0kB
        DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=120ns
                               IORDY flow control=120ns


[root@donslap ~]# hdparm -d1 /dev/hdc

 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)
any suggestions on fixes are much appreciated. thanks.

edit: whups! just saw the laptop forums here. please close this as i will post in the appropriate forum.

Last edited by megaspaz; 09-01-2003 at 02:24 PM.
Old 09-03-2003, 01:43 PM   #2
Senior Member
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
try adding the following line to the /etc/modules.conf file

options hd-cd dma=1

save and reboot
(gasp, a reboot needed)

after reboot
try manually executing the hdparm -d1 command
Old 09-03-2003, 02:58 PM   #3
Mad Merlin
Registered: Aug 2003
Location: Approximately here.
Distribution: Mandrake 9.1
Posts: 86

Rep: Reputation: 15
I'd try a newer kernel if I were you, or try throwing the appropriate ac patch onto a kernel of your choice. I had a similar problem with enabling DMA on my IBM Thinkpad T40 for the hard drive and the CD-RW/DVD drive, the IDE controller wasn't supported by the Mandrake 9.1 kernel yet, after i tried 2.4.22-rc1-ac1, DMA worked like a charm.

So basically, try a newer kernel or a newer distro.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't enable DMA Timeturtle Linux - Hardware 9 06-03-2004 05:34 PM
Enable DMA ust Linux - General 1 02-09-2004 01:28 AM
CDRW SuSE 8.2 DMA set problem lacerto Linux - Laptop and Netbook 0 11-11-2003 03:50 PM
How to enable DMA? Piero Linux - Hardware 14 07-21-2003 06:05 AM
cdrw dma problem ??? jakethefake General 3 04-17-2002 10:37 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:01 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration