Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 08-29-2003, 11:53 PM   #1
Registered: Aug 2003
Location: Manila, Philippines
Distribution: RH
Posts: 43

Rep: Reputation: 15
cannot detect my cdrom

can anybody help me how to detect my cdrom i use the following command:

mount -iso9660 /dev/cdrom /mnt/cdrom

the errors are:
mount: block device /dev/cdrom is write protected
mount: medium not found

what wrong with this i even use the cd rom whe i installed th linux RH7.3

Old 08-30-2003, 12:55 AM   #2
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Rep: Reputation: 30
have u tried to mount the cdrom while u were root
Old 08-30-2003, 09:37 AM   #3
koen plessers
Registered: Aug 2003
Location: Belgium
Distribution: Mint
Posts: 191

Rep: Reputation: 30

I think it should be

mount -t iso9660 /dev/cdrom /mnt/cdrom

where the -t option stands for "file system" and what follows (iso9960) is the actual file system you want to use.

If you type "-iso9960" mount thinks it is an option.

type "man mount" for more details.
Old 08-30-2003, 12:18 PM   #4
Senior Member
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
mount: block device /dev/cdrom is write protected
It is telling you that the CD-ROM is read-only.
mount: medium not found
This error tells you that there is no CD-ROM in the CD drive.
Old 08-30-2003, 07:18 PM   #5
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Originally posted by koen plessers
I think it should be

mount -t iso9660 /dev/cdrom /mnt/cdrom

where the -t option stands for "file system" and what follows (iso9960) is the actual file system you want to use.

If you type "-iso9960" mount thinks it is an option.
That's correct.
What does the CD-ROM's entry in /etc/fstab look like?
Old 08-30-2003, 08:15 PM   #6
LQ Newbie
Registered: Aug 2003
Location: panama
Distribution: Redhat/Slackware
Posts: 7

Rep: Reputation: 0
if you are using RedHat 7.3 you could mount your cdrom in a easiest way.
does not matter if you are root or what because the fstab have the user option. (noauto, user, bla bla bla)

whatever@whatever# mount /mnt/cdrom [enter]

that's all.

if you really belive that is a hardware problem, just reseat the conection of the ribon cable (remember to ground yourselv and disconect the power cable). But the thing is.. if the system is able to boot from the cd is because the hardware works.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
The CDROM and FLOPPY can't detect file Mathsniper Linux - Hardware 2 04-16-2005 12:13 AM
Slackware 10.0 Boots, But Setup cant detect CDROM Terei Slackware - Installation 8 02-02-2005 03:13 PM
cant detect cdrom drive from Linux shenoy Linux - Newbie 1 08-30-2004 08:04 AM
old BIOS (1992) won't detect my cdrom drive; BIOS says: neither IDE prots enabled carbono Linux - Hardware 5 05-18-2004 12:07 PM
cdrom detect huno Slackware 4 10-06-2003 03:54 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:36 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration