LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-01-2003, 06:00 PM   #1
sforbes
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Rep: Reputation: 0
Can not connect to the internet


I just installed Red Hat 9 and everything seemed to go well except my wireless card (buffalo pcmcia) is not able to connect to the internet. Under network configuration it shows that the device is active and the dns shows a primary and secondary ip address which is the same. The dns search path also shows a setting that is similar to my Windows PC's. So it looks like the card is talking to the access point but that is about it. When I bring up a browser it is unable to find any sites.

Output from /sbin/cardctl ident

Socket 0:
product info: "MELCO", "WLI-PCM-L11", Version 01.01"
maanfid: 0x0156, 0x0002
function: 6 (network)

I just started playing around with this today so pretend that I know nothing about linux!

Thanks for any help
 
Old 10-02-2003, 03:00 AM   #2
Mirar
Member
 
Registered: May 2003
Location: Falun, Sweden
Posts: 62

Rep: Reputation: 15
How is your network setup? Do you have a DHCP server, or static IPs? I guess you have DHCP, since you say you get the same DNS as the windows machines (if you didn't set it when installing redhat).
Do you get any intereting log statments in /var/log/messages or .../syslog?

What does ifconfig say?
 
Old 10-02-2003, 10:47 AM   #3
sforbes
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Original Poster
Rep: Reputation: 0
I have an access point (Buffalo Air Station) that has dhcp and dishes out internal ip's.

/var/log/message showed:

localhost ifup: failed; no link presesnt. Check cable?
localhost network: Bringing up interface eth0: failed

When I reboot I get the message:
redhat-config-network:
eth0 has an alias to module tulip in modules.config, instead of currently loaded module orinoco_cs!

doing an ifconfig shows that eth0 has no ip address

If I delete eth0 and reset it eth0 then shows it has an ip address but still no dice on getting outside.

ifconfig shows:
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 frame:0

I am able to get to the dsl modem config page via browser but checking the diagnostics it shows that the ip is failing. I know that the modem and the air station are working because it works for my other computers. thanks for any help!
 
Old 10-02-2003, 11:20 AM   #4
sforbes
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Original Poster
Rep: Reputation: 0
ok got it working and here is what was wrong. I figured that everything seemed to be working except I was not getting any replies from requests sent out. So I checked the security settings and sure enough I needed to check eth0 as a trusted device because I had origionally set the security setting to High. Once I checked this I was able to get outside my modem. Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM
Can't connect to Internet Galphar Linux - Newbie 13 08-24-2003 04:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration