Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 12-01-2012, 01:09 PM   #1
Registered: Jul 2003
Location: Utah
Distribution: Gentoo FreeBSD 5.4
Posts: 150

Rep: Reputation: 16
"Can't find root filesystem / error mounting /dev/root" when booting to new kernel

I am trying to upgrade my kernel from 2.6.18-274 to 2.6.39 for some wireless card drivers.
When I boot into the new kernel I get the "Can't find root filesystem / error mounting /dev/root" googling led me to this page
From what I am reading seems to be an issue with a driver for my SATA controller or HD, but I can't find what option I need to add to the kernel.
Doing a diff from the old initrd to the new one gives me the following:
root-> diff /tmp/kafter /tmp/kbefore 
> lib/dm-message.ko
> lib/dm-region_hash.ko
> lib/dm-raid45.ko
< lib/dm-region-hash.ko
> lib/dm-mem-cache.ko
Do I need any of those? not sure if I would need dm-raid45.ko as I am not running a raid.
I have the same SATA and IDE options configured for both kernels so not sure what else to look for, any help is appreciated.

Additionally here is the HW info:
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
	Subsystem: Hewlett-Packard Company Unknown device 3006
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 233
	I/O ports at 1818 [size=8]
	I/O ports at 1830 [size=4]
	I/O ports at 1820 [size=8]
	I/O ports at 1834 [size=4]
	I/O ports at 14f0 [size=16]
	Capabilities: [70] Power Management version 2

root-> smartctl -a /dev/sda

Device Model:     WDC WD5000AADS-00S9B0

Last edited by sal_paradise42; 12-01-2012 at 01:26 PM. Reason: adding relevant information
Old 12-01-2012, 04:03 PM   #2
Registered: Jul 2003
Location: Utah
Distribution: Gentoo FreeBSD 5.4
Posts: 150

Original Poster
Rep: Reputation: 16
I fixed it with the help of this link

Needed this option: CONFIG_SYSFS_DEPRECATED_V2=Y


kernel, sata

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS "mount: could not find filesystem '/dev/root'" newDevlp Linux - Kernel 3 02-04-2012 04:51 AM
FC6: "mount: could not find filesystem '/dev/root'" sancho Fedora - Installation 16 04-07-2010 08:35 PM
Booting from RAID 1, hang at "waiting for root filesystem" GBW88 Linux - Server 2 08-26-2007 06:40 PM
FC6: "mount: could not find filesystem '/dev/root'" cheerful Fedora - Installation 2 07-27-2007 03:36 PM

All times are GMT -5. The time now is 02:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration