LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-15-2003, 03:39 PM   #1
Wiggie
LQ Newbie
 
Registered: Mar 2003
Distribution: SuSe
Posts: 2

Rep: Reputation: 0
Unhappy can't see first windows hdd


I recently installed suse 8.1 on my secondary hdd which is split into 2 partitions; one is ntfs and the other is linux. when linux starts it automatically mounts the ntfs partition of the 2nd hdd but it cannot see the first hdd at all. i have win xp on the first hdd plus other ntfs partitions.

when the pc boots grub starts up [ it boots the 2nd hdd first ] and when i choose windows from the menu it trys to boot from the 2nd hdd which has an ntfs partition but is not bootable.

mind you when i installed linux i unplugged my 1st hdd just in case i screw something up and wipe it clean [ i did it before with red-hat - learned my lesson ] and then i plugged it back in after the install.

partitioner in kde sees the first hdd partitions but it tells me they are not mounted.

how do i fix these problems [ boot from grub to windows and mount 1st hdd]

i got a K7 at 1.4, 512 ram, 1st hdd 40 Gb and 2nd is 80 Gb.

Thanks
 
Old 03-15-2003, 03:47 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,671

Rep: Reputation: 218Reputation: 218Reputation: 218
You only need to change SuSE configuration. Boot into it. Open a terminal, use su to become root, then run
fdisk /dev/hda
use 'p' to list the partitions (partitions from first hd). Note them down with names like hda1 etc. Then try to mount one of them manually (let's say you have hda1):
mkdir /mnt/win1
mount -t ntfs /dev/hda1 /mnt/win1
Then look into /mnt/win1 directory. One of your Windows partitions shoule be there.
NOTE: If it's not ntfs but fat32, use -t vfat instead of -t ntfs.

To make them mount at boot open /etc/fstab and add a line for every partition from first disk, something like:
/dev/hda1 /mnt/win1 ntfs defaults 0 0
 
Old 03-15-2003, 04:23 PM   #3
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
LINUX can read NTFS (with add on module) but writing to it is experimental. I recommend you convert your NTFS partitions to FAT32 using Partition Magic or something similar. Windows XP doesn't have any problems reading and writing FAT32.

Sorry, I don't remember the link that explains how to boot to Windows XP that is using NTFS partitions that was posted a few days ago.

LILO is more stable than GRUB but GRUB can still be used. GRUB may take more work than LILO.

BTW, my brother doesn't have any problems with Windows XP on a 40 gigabyte partition using FAT32.

IMO, NTFS should be used with the computer will be used as a Windows server. FAT32 should be used for home, office, and workstations. Why do people insist on using NTFS for Windows XP?
 
Old 03-16-2003, 12:59 PM   #4
Wiggie
LQ Newbie
 
Registered: Mar 2003
Distribution: SuSe
Posts: 2

Original Poster
Rep: Reputation: 0
thanx guys, i got it fixed.
however i don't have acces to them in normal user mode. in root i can go and browse the drives. so i tried to change permission while logged into root and it still won't let me. what am i doing wrong?

also when i try to make grub load the windows from hda1 it won't do it either. [i'm no expert so i'm not using the expert mode instead i'm using the gui one]
 
Old 03-17-2003, 01:47 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,671

Rep: Reputation: 218Reputation: 218Reputation: 218
Make sure the directory you created to mount the partition has permissions that allow other users to read it. If you need to change them, first unmount the partition, change permissions and mount again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing My Windows HDD yourwar Linux - Newbie 10 08-15-2005 05:16 AM
external hdd no x-windows smorehou Linux - Hardware 1 08-23-2003 11:08 PM
How to mount a windows HDD Lotmr Linux - General 2 07-26-2003 11:53 AM
Windows won't recognize HDD pkick Linux - Newbie 9 05-21-2003 07:21 PM
how can i let windows to have the hdd of linux? sagrast Linux - General 7 03-16-2003 11:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration