LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-03-2004, 05:25 PM   #1
zombi3
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
can't mount scsi emulated cdrom


This all started when i used xcdroast to burn a cdrom. xcdroast adviced i should use scsi emulation so i when with that; the burning when fine until i tried to mount.

Slackware<best Distro>
Kernel 2.4.22

1.I installed ide-scsi module
ide-scsi 9424 0

2. I edited fstab
/dev/sr0 /cdrom iso9660 noauto,user,ro, 0 0

3. Error is
bash-2.05b# mount -t iso9660 /dev/scd0 /cdrom
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems.

4.
DMESG

ide_setup: hdc=ide-scsi
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
hdc: attached ide-scsi driver.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 24x/16x writer cd/rw xa/form2 cdda tray
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)
ide-scsi: hdc: unsupported command in request queue (0)

Last edited by zombi3; 01-03-2004 at 05:27 PM.
 
Old 01-03-2004, 07:36 PM   #2
zombi3
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
The problem was a bad burn
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.4.27 and hdd emulated as scsi? r_jensen11 Linux - Hardware 2 08-13-2004 07:29 PM
disable dma on scsi emulated ide secondry-slave qwijibow Linux - Software 7 11-04-2003 09:55 PM
scsi emulated cd drive cuases system lockups :( qwijibow Linux - Newbie 0 08-21-2003 09:19 AM
Playing CDs with SCSI emulated Burner PiMoGo Linux - General 3 11-11-2002 02:00 AM
Unable to play audio CDs in a scsi emulated CDRW David Incoll Linux - Newbie 6 04-14-2002 07:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration