LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-06-2006, 11:15 PM   #1
justanothersteve
Member
 
Registered: Aug 2005
Location: Missouri, USA
Distribution: Gentoo
Posts: 161

Rep: Reputation: 30
Can't Mount Fat32 partition


I am having a problem mounting my fat32 partition. It keeps returning

Code:
cetra linux # mount /music
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
I have made sure that MS-DOS and FAT filesystems are compiled into my kernel. Dmesg returns with:

Code:
FAT: codepage cp850 not found
Here is my fstab:
Code:
/dev/hda2       /boot           reiserfs        noauto,noatime,notail   1 2
/dev/hda3       /               reiserfs        noatime,notail          0 1
/dev/hda4       /home           reiserfs        noatime,notail          0 0
/dev/hdb1       /music          auto            noatime,                0 0
/dev/hdb2       none            swap            sw                      0 0
/dev/hdc        /dvd            auto            noauto,ro               0 0
/dev/hdd        /cdr            auto            noauto,ro               0 0
/dev/fd0        /mnt/floppy     auto            noauto                  0 0

proc                    /proc           proc            defaults        0 0
shm                     /dev/shm        tmpfs           nodev,nosuid,noexec    0 0
The partition exists, here's fdisk -l

Code:
cetra linux # fdisk -l /dev/hdb

Disk /dev/hdb: 13.5 GB, 13578485760 bytes
16 heads, 63 sectors/track, 26310 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1       23252    11718976+   b  W95 FAT32
/dev/hdb2           23253       26310     1541232   82  Linux swap / Solaris
Any Ideas on how to mount this partition?
 
Old 08-07-2006, 12:03 AM   #2
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
Greets. Did you already tried by hand like this?:
# mount -t vfat /dev/hdb1 /music
or may be modifying this line:
/dev/hdb1 /music auto noatime, 0 0
like this?:
/dev/hdb1 /music vfat defaults,noatime 0 0
 
Old 08-07-2006, 12:03 AM   #3
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Code:
FAT: codepage cp850 not found
Check your kernel config. Make sure NLS_CODEPAGE_850 is enabled. In make menuconfig (for 2.6 kernels) it can be found in:

File systems -> Native Language Support -> Codepage 850 (Europe)
 
Old 08-07-2006, 12:34 AM   #4
justanothersteve
Member
 
Registered: Aug 2005
Location: Missouri, USA
Distribution: Gentoo
Posts: 161

Original Poster
Rep: Reputation: 30
runnerfrog: both of those suggestions yielded the same results

zhangmaike: that is what is listed in my kernel config.
 
Old 08-07-2006, 12:53 AM   #5
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Is codepage 850 set to be built-in or built as a module?
 
Old 08-07-2006, 01:06 AM   #6
justanothersteve
Member
 
Registered: Aug 2005
Location: Missouri, USA
Distribution: Gentoo
Posts: 161

Original Poster
Rep: Reputation: 30
its set to be built in......is it the correct codepage?
 
Old 08-07-2006, 03:09 AM   #7
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
Sure looks like it... I've never had this error, nor do I routinely mount FAT filesystems, but the only codepage listed anywhere in the kernel config containing the number 850 is the one that you apparently already have built in.

Any other kernel messages mentioning cp850?
 
Old 08-07-2006, 04:22 PM   #8
runnerfrog
Member
 
Registered: Jul 2006
Location: Paraná, Argentina
Distribution: Frugalware 0.6 (Terminus) - Kubuntu 7.04 (Feisty Fawn Herd 5)
Posts: 217

Rep: Reputation: 31
The best way of having installed the codepages -in my experience- is as modules.
So let's try to change for utf8 instead, in fstab:
/dev/hdb1 /music vfat defaults,utf8,umask=007 0 1
and reboot, just in case we're messing with automount; many people say that rebooting is the best way of restarting automount (but: /etc/rc.d/init.d/autofs reload). If it works, eventually you can add "noatime".
To see messages about automount (just in case): tail -100 /var/log/messages | grep automount
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
How can I mount a FAT32 Partition PulsarSL Linux - Newbie 10 08-28-2005 05:43 PM
can't mount fat32 partition warpengi Slackware - Installation 6 09-17-2004 04:56 PM
Can't mount FAT32 partition EcceVery Debian 5 09-13-2004 06:53 AM
mount of fat32 partition mys71 Red Hat 2 05-09-2004 03:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration