LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-09-2006, 11:14 AM   #1
JacekZ
Member
 
Registered: Sep 2005
Location: Notts, England
Distribution: Debian 10
Posts: 71

Rep: Reputation: 15
Can't format a floppy in FC5


My /etc/fstab:

Code:
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
LABEL=/home             /home                   ext3    defaults        1 2
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda3         swap                    swap    defaults        0 0
/dev/fd0         	/mnt/floppy             auto    noauto,rw,user  0 0
/dev/hdb5               /mnt/HD2                vfat    noauto,rw,user  0 0
I added the last two lines as root, the before last one for the floppy. This means I can now use the floppy drive as a regular user via nautilus (with a bit of awkwardly persistent clickling) or by typing at a console:

Code:
mount /mnt/floppy
umount /mnt/floppy
In nautilus there is a floppy icon, and likewise on the desktop (only while it is mounted in the latter case).

Contrary to what I've read on various web pages right clicking on the icons does not offer any format options in the context menu.

Typing 'gfloopy' in a console is slighly more promising, this starts the format gui but it closes immediately with the error:
"Cannot initialise device"
"Unable to open any device, formatting cannot continue."

The floppy command behaves thus:

Code:
$ floppy --format /dev/fd0
floppy 0.12 Copyright 2001, Double Precision, Inc.
floppy: device /dev/fd0 not found in /etc/floppy
..this is explained by there not being an /etc/floppy file on the system.

All of which begs the question, how should one go about formatting floppies on fc5? I must admit to being confused by all the /dev/fd* files (ending with lots of numbers) which seem to have something with what is said in man fd - all of which went over my head somewhat. Perhaps is it some odd default security or selinux setting at work? Any ideas?
 
Old 09-10-2006, 02:59 AM   #2
sn68
Member
 
Registered: Oct 2005
Distribution: FC5
Posts: 338

Rep: Reputation: 30
Try replacing auto with vfat & noauto with exec in the /etc/fstab and do mount -a
ie change
/dev/fd0 /mnt/floppy auto noauto,rw,user
to
/dev/fd0 /mnt/floppy vfat exec,rw,user
 
Old 09-11-2006, 05:18 PM   #3
JacekZ
Member
 
Registered: Sep 2005
Location: Notts, England
Distribution: Debian 10
Posts: 71

Original Poster
Rep: Reputation: 15
Thanks sandeepnatu, didn't work though, same behaviour as before.
 
Old 09-11-2006, 09:20 PM   #4
sn68
Member
 
Registered: Oct 2005
Distribution: FC5
Posts: 338

Rep: Reputation: 30
I haven't used floppy drive for a long time now, but managed to get a floppy and in my in my case two things worked

First remove the floppy line from fstab and do umount /mnt/floppy
then you can right click floppy drive icon inside the computer icon on Desktop and you will find "Format" on the context menu
else use Gparted and format

Last edited by sn68; 09-11-2006 at 09:41 PM.
 
Old 09-12-2006, 06:32 PM   #5
JacekZ
Member
 
Registered: Sep 2005
Location: Notts, England
Distribution: Debian 10
Posts: 71

Original Poster
Rep: Reputation: 15
Thanks sandeepnatu,
if I remove the entry in fstab, then I get no floppy icon to click anywhere. I have to su mount the floppy to get the icon again, but then I'm back where I started. As for gparted, the gui does not have any access to floppies, just hard drives. It is reasuring though odd that your fc5 has the facility. I did a custom install so perhaps something got disabled along the way.. I might just have to live with it until fc6 comes along?
Jacek
 
Old 09-12-2006, 07:39 PM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
I use fdformat along with mkfs, different versions of mkfs for different file systems. For example:
To format the floppy as vfat ...
Code:
fdformat /dev/fd0
mkfs -t vfat /dev/fd0
or Linux ext2 ...
Code:
fdformat /dev/fd0
mke2fs -m 0 /dev/fd0
There are a bunch of options to fdformat in the man pages.
Also, you may want to look at mtools.
 
Old 09-13-2006, 06:05 PM   #7
JacekZ
Member
 
Registered: Sep 2005
Location: Notts, England
Distribution: Debian 10
Posts: 71

Original Poster
Rep: Reputation: 15
homey,
I had to add /sbin to the command to make it work thus:
Code:
/sbin/mkfs -t vfat /dev/fd0
then it worked!
Many thanks
Jacek
 
Old 09-13-2006, 06:21 PM   #8
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Sorry, I was doing that as root user ( su - )
Glad it works for you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Floppy format MoonlitSky Fedora 1 08-09-2006 03:11 AM
To format a floppy?... mufy Linux - Newbie 3 11-02-2004 05:39 AM
How do i format a floppy? Braveheart1980 Linux - General 6 02-17-2004 04:46 PM
How to format a floppy..... Santorres Linux - Newbie 2 12-10-2003 09:18 PM
format floppy jeanchristophe Linux - Newbie 4 05-17-2003 05:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration