LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-22-2003, 05:11 PM   #1
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Rep: Reputation: 15
Can't enable 3D


I have a FX 5200 card, and I installed the driver for it, but after that, when I went into Sax2, I clicked enable 3-d acceleration. It said it would be enabled when I restarted the graphics system. I restarted the computer and when I went into Sax2 again, it was unchecked. How can I get it to enable?
 
Old 11-22-2003, 06:51 PM   #2
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
You shouldn't have to enable anything. You should install NVIDIA-Linux-x86-1.0-4496-pkg2.run from a text console (when you have logged out of the X server). Then edit your "X86Config or XF86Config-4" and go to the device section and change "nv" to "nvidia" under the Device--> Driver part. If that doesn't work, add " Option "NvAGP" "1" "under everything else but before "endsection". Also make sure you have your kernel source installed under "/usr/src" . There should be a folder in there that has the same name as your kernel after you install the source. And a folder called "linux". The linux folder is just a link to the source but is needed. If it isn't there, do :

"ln -s /usr/src/(whatever your source folder is called) /usr/src/linux" in the usr/src folder.

This will create a symbolic link needed for the Nvidia install.

You might have already done this, but if not, this is the way to install the Nvidia dirvers using the *.run file under almost all of the IA32 Linux Distro's.
 
Old 11-22-2003, 09:28 PM   #3
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
How do I edit the X86Config file?
 
Old 11-23-2003, 09:55 AM   #4
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
Do you have the kernel source installed with a symbolic link and the Nvidia driver downloaded to your root directory?
 
Old 11-23-2003, 04:13 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
How to edit a file

Quote:
Originally posted by yzrider210
How do I edit the X86Config file?
To edit the XF86Config file, you need to go to a console and use a text editor. I don't know anything about the SuSE distro, but you should be able to search for that either here in LQ or at www.google.com/linux. Most of the search results at Google will lead you back to LQ.

If you are using the KDE Desktop, click on the icon at the bottom of your screen that looks like a monitor with a shell overlay. This will open a terminal. From there you will need to login as root, as this file cannot be edited by a normal user, but only by the superuser. If you don't have a desktop like KDE or Gnome where you can get a console, just hit the Ctrl+Alt+Backspace keys and that will take you to command line.

Once you're there, you need to login as root (super user) by typing su and then entering your password, like this ->

mingdao@paul:~$ su
Password:

Next you will need to open the XF86Config (or XF86Config-4, which SuSE has) file with a text editor. SuSE should have either pico, nano, or vi installed by default. Try pico first, and if that doesn't work, try nano and then vi. Pico and nano are slightly easier to use. They have a menu at the bottom of the screen which displays the functions you need to edit (similar to a DOS screen), where vi doesn't. In either of them, your mouse will not move the cursor. You'll have to do that with the arrow keys of your keyboard. The mouse will only highlight text, which can then be copied somewhere else by pressing down on the scroll wheel. So open the file like this ->

root@paul:/home/mingdao# pico /etc/X11/XF86Config

Then follow the instructions that came in the README file at the Nvidia site where you got your driver ->

README - Text Version

Code:
__________________________________________________________________________

(sec-03) EDITING YOUR XF86CONFIG FILE
__________________________________________________________________________

When XFree86 4.0 was released, it used a slightly different XF86Config
file syntax than the 3.x series did, and so to allow both 3.x and 4.x
versions of XFree86 to co-exist on the same system, it was decided that
XFree86 4.x was to use the configuration file "/etc/X11/XF86Config-4"
if it existed, and only if that file did not exist would the file
"/etc/X11/XF86Config" be used (actually, that is an over-simplification
of the search criteria; please see the XF86Config man page for a complete
description of the search path).  Please make sure you know what
configuration file XFree86 is using.  If you are in doubt, look for a
line beginning with "(==) Using config file:" in your XFree86 log file
("/var/log/XFree86.0.log").  This README will use "XF86Config" to refer
to your configuration file, whatever it is named.

If you do not have a working XF86Config file, there are several ways
to start: there is a sample config file that comes with XFree86,
and there is a sample config file included with the NVIDIA driver
package (it gets installed in /usr/share/doc/NVIDIA_GLX-1.0/).
You could also use a program like 'xf86config'; some distributions
provide their own tool for generating an XF86Config file.  For more
on XF86Config file syntax, please refer to the man page.

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

        Driver "nv"
    (or Driver "vesa")

with 

        Driver "nvidia"  

In the Module section, make sure you have:

        Load   "glx"

You should also remove the following lines:
      
        Load  "dri"
        Load  "GLcore"

if they exist.  There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver.  Please see
Appendix D for a complete list of these options.

Once you have configured your XF86Config file, you are ready to restart
X and begin using the accelerated OpenGL libraries.  After you restart X,
you should be able to run any OpenGL application and it will automatically
use the new NVIDIA libraries.  If you encounter any problems, please
see the FREQUENTLY ASKED QUESTIONS section below.
That README file should have all the information you need to get the card going. I'm using the same card in Slackware, and used it in Debian, and following those instructions set it up just fine for me.

I don't understand or even know about Sax2 because that isn't on a Slackware or Debian system. If this is a Sax2 problem, then perhaps you should find out why Sax2 didn't save your settings.

NB: Google is your friend, and a thorough search there and here at LQ will answer your questions a lot of times.
 
Old 11-24-2003, 05:40 PM   #6
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
Ok, I went through the XF86Config file, and everything was already done. Sax2 still says that 3D is not enabled. How do I fix that?
 
Old 11-24-2003, 06:21 PM   #7
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
Forget about Sax2 for now. Again, do you have the kernel source installed with a symbolic link and the Nvidia driver downloaded to your root directory?

And if your XF86Config file is already good to go, then you're already one step ahead.

If not install the source. If it's a RPM it will probably create a symbolic link for you. If not, do : ln -s /usr/src/(whatever kernel source folder is called) /usr/src/linux

When all of that is done, you want to log out of the X-Server. Change the way you log in by setting up the system to start in "text" mode. Once logged into root without the X-serever, run the Nvidia driver and follow the steps. If you have the kernel source installed (with a symbolic link) you should fly through it with no prob's.

I still find it odd that you can still log on to the X-Server when your XF86Config (-4 maybe) has been configured for Nvidia. How did you install the drivers?
 
Old 11-24-2003, 11:55 PM   #8
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
with a symbolic link and the Nvidia driver downloaded to your root directory?
No idea what that means

First, I got out of X-Window and installed the NVIDIA driver. Then I logged in, went to Yast, and did a search for Kernel-source, came up with one thing and told it to install. That is what I've done so far. I don't remember if the file was an RPM.

Whenever KDE starts, the NVIDIA splash screen comes up, so I know somethings working right.......
 
Old 11-25-2003, 01:04 AM   #9
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
How do you know 3-D isn't enabled? Have you tried opening a console, as root, and typing glxgears - try it and post what you get.
 
Old 11-25-2003, 04:31 PM   #10
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
If you are getting the nvidia flash screen, then the only problem you should have (if any of course) is to make sure the agp port is enabled. " cat proc/driver/nvidia/agp/status ".

That will tell you if it is. But regardless what of Sax2 says, I think you already have 3D enabled. Actaully, if you are getting the nvidia splash screen, then i'm pretty much positive you have OpenGL 3D enabled. :-)

Do the gears thing too "glxgears".
 
Old 11-25-2003, 05:48 PM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
I don't know about Sax2, but you definitely have the Nvidia driver installed.

Also, there is no reason to mess with the symbolic link, and you shouldn't download the Nvidia driver to your root directory (don't download from the internet as root), but rather, to your /home/username directory.

Just open a console and type glxgears. If you're getting somewhere around 3000 fps you have 3D and it's good enough for games.
 
Old 11-29-2003, 10:30 PM   #12
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
OK, thanx. I was getting about 2800 frames a second, so I guess thats good. I still don't get why Sax2 doesn't say 3D is enabled. I'm wondering (I don't know that much about linux, so this isn't a very-well educated guess) if maybe since I didn't use the driver provided by SuSE, but the one provided by NVIDIA, maybe Sax2 didn't recognize that 3D is enabled. Is this possible, or way off?
 
Old 12-25-2003, 08:52 PM   #13
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Sorry, I can't answer that question. I've never used SuSE or this Sax thing. However, if you're getting 2800 FPS you've got 3D acceleration. How does it look?
 
Old 12-28-2003, 12:02 PM   #14
yzrider210
Member
 
Registered: Oct 2003
Location: Nor Cal
Distribution: SuSE 9.0 Pro
Posts: 130

Original Poster
Rep: Reputation: 15
I've been playing the UT2003 demo and it looks great. Seems to run better than BF1942 on my Windows disk.
 
Old 12-28-2003, 05:59 PM   #15
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
Cool!!! I'm glad you got 3D accel.

My little bit of experience with *nix is that once I have things working, it's much funner, easier, and more efficient that Windoze. Slackware just makes sense, and works really well!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLease help cannot enable DMA sendas4 Linux - Newbie 12 04-09-2007 12:36 PM
How to enable modules beejayzed Linux - Newbie 1 02-02-2004 05:18 AM
How to enable DMA? Piero Linux - Hardware 14 07-21-2003 06:05 AM
enable xinetd rlasse Linux - Newbie 4 07-17-2003 01:08 PM
Should i enable zlib? jim64 Linux - Software 0 07-12-2003 06:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration