-   Linux - Hardware (
-   -   Camera on USB connection not detected (

redhat beginer 04-21-2005 09:55 PM

Camera on USB connection not detected
I plugged in my canon powershot a75 camera via the USB plug. Nothing. Figure I'll restart, leaving it in, nothing.

Then I command
dmesg |grep sd
because a helpful person suggested this will display and SCSI devices, such as USB ports. Nothing is displayed. There should at least be the ports showing right? Even if not the camera?

Do I need those 'Twain' things and what not???

mjrich 04-21-2005 11:49 PM

Can you read from other USB devices (thumbdrives and so on) ? If not, and the above grep command came up blank after plugging in anything usb related, then you're probably missing kernel support for usb storage. If you have a look at the tutorial over here then you should be able to get it going.



PS. No, you don't need Twain for usb.

redhat beginer 04-22-2005 05:32 PM

from the link

password: (enter root password here)
#cd /usr/src/linux
#make menuconfig

from that i receive
"make: *** No rule to make target `menuconfig'. Stop."


I also tried config and xconfig, all to no avail.

edit to add:
When i command ls while in /usr/src/redhat, all i get is

Raafi 04-22-2005 08:55 PM

i have to agree with the beginner, those "how to" instructions dont work

nothing new, just gotta keep digging

if anyone knows how to get my fc3 to recognize my creative webcam, i would be greatly appreciative

buffed317 04-22-2005 09:38 PM

a program called gtkamis what i use for my kodak camera. here is the link.

Raafi 04-23-2005 07:08 AM

i went here and it worked

but thanks buffed, really appreciated it

mjrich 04-23-2005 11:07 PM

Great to hear that you've got it all working :)

If you ever do feel the need to recompile your kernel, then you'll need the complete kernel sources (not just the headers, which is possibly what you have now). Just download them from or your nearest FC mirror, and bob's your uncle.



redhat beginer 04-24-2005 12:18 PM

I am still unable to resolve the problem mentioned in my last post. Also, , looks like its a program for working with the camera once the USB port recognizes it, no?

And I don't understand what is supposed to be. It looks like its supposed to be an entire kernel/distribution, not something specific to USB ports and RHEL3.

Raafi 04-24-2005 05:02 PM


i untarred it, and it worked

i dont know how, but it did

since i have a creative nx pro, the one they said i needed is still under construction

thats all i can say, if it works for you, great, if not, you gotta keep looking, i went four months without my cam until this weekend

All times are GMT -5. The time now is 10:21 PM.