LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   C-Media PCI soundcard - audio skipping (http://www.linuxquestions.org/questions/showthread.php?t=4175445951)

Poprocks 01-16-2013 09:29 PM

C-Media PCI soundcard - audio skipping
 
My onboard soundcard is busted (audio only works out of one channel), so I went and bought a $10 PCI soundcard. The relevant lspci entry is:

Code:

05:00.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
At first alsa was trying to keep using my onboard Intel card, but with some modprobe.conf magic it was easy to switch the default to my C-Media card.

Audio works out of both channels just fine, but it keeps skipping (or hiccupping or stuttering, whatever you want to call it). This is reproducible at least for Flash (ie, Youtube) and Audacious.

I tried running Audacious in a terminal. Every time the audio skips, the following error appears:

Code:

ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
I thought maybe alsa was getting confused that there were two soundcards, so I tried unloading the modules for my onboard card. Same problem. I then tried disabling the onboard card in the BIOS entirely. Same problem.

I'm wondering if anyone can offer any tips on this. It's been driving me nuts and I've googled and googled and it seems that no one else in the world is having this issue.

I guess I could go out and buy yet another soundcard and take this one back, but by all accounts this seems to be a common chipset so I can't understand why I'm having this issue.

Slackware 14.0, 32-bit SMP kernel. No customizations.

business_kid 01-17-2013 08:56 AM

CMI 8738? It's been a long time since I had one of those.

It's the driver. A good idea if you can still do it is to use the OSS driver because IIRC that card was old/junky enough to make it to Ireland 10 years ago, and alsa was those heads who said "Sound isn't good enough; we're going to rewrite from scratch and rewrite all the drivers as well, except we're going to do it better:-/." I think cmipci was the module name. Therer's a doc in the kernel about it. Read up.

Poprocks 01-20-2013 05:52 PM

Thanks. I knew it had to be an old chipset because it has a bloody gameport. I mean, really, who needs one of *those* these days?

The documentation didn't reveal anything earth-shattering. I think I'll just buy a slightly less shitty card. I really don't want to recompile my kernel to include OSS support just to get a $10 soundcard to work, and then have it only be able to play one sound at once (this card has no hardware mixing capabilities).


All times are GMT -5. The time now is 05:16 AM.