LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   BTTV (TV Wonder VE) Channel Offset? (+1) (https://www.linuxquestions.org/questions/linux-hardware-18/bttv-tv-wonder-ve-channel-offset-1-a-206385/)

jlschwab 07-17-2004 06:09 PM

BTTV (TV Wonder VE) Channel Offset? (+1)
 
Heya folks;

I am running slackware 10.0 on custom 2.6.7 kernel.
Very happy with it so far, but I have noticed that my tv in card

ATI Wonder VE (the cheapy $50, non-remote, old one)

Comes up as "bttv", which is correct and sound works and perfectly clear picture.
(Using tvtime, btw).

But in tvtime, xawtv or any others I have tried, the channels are offset by 1.
Like if I goto channel "37" on tvtime it tells me its on 37, but im actually watching 36.


I have comcast normal cable in USA, also tv card is set to NTSC.

Any ideas on how to fix this or what would cause it?

Thanks.
-Jason

Phorem 07-18-2004 01:08 AM

This was happening to me as well. All channels were off by one with my ATI Wonder VE Remote ( the remote works fine in Linux too :-D ) in TvTime. When you modprobe the bttv driver add tuner=2, for example :

root#> modprobe bttv tuner=2

When you "dmesg" you should see the card now using NTSC.

jlschwab 07-18-2004 03:11 AM

Hmm, I did that, as follows:

rmmod bttv
modprobe bttv tuner=2

Then tried the tv again (tvtime) made no difference, even rebooted, made no difference

Here is my dmesg:

(dmesg | grep -i tv)

bttv: driver version 0.9.14 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:02:02.0, irq: 18, latency: 32, mmio: 0xd8000000
bttv0: detected: ATI TV Wonder/VE [card=64], PCI subsystem ID is 1002:0003
bttv0: using: ATI TV-Wonder VE [card=64,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=2
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok

I dont see anything about it using NTSC?

I set my tvtime program to NTSC, but that also made no difference.

-Jason

Phorem 07-18-2004 04:11 AM

This is what i get with dmesg after modprobe bttv tuner=2. Maybe your problem might have something to do with i2c.

Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:00:0d.0, irq: 18, latency: 64, mmio: 0xefe00000
bttv0: detected: ATI TV Wonder/VE [card=64], PCI subsystem ID is 1002:0003
bttv0: using: ATI TV-Wonder VE [card=64,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: using tuner=2
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tuner: chip found at addr 0xc0 i2c-bus bt878 #0 [sw]
tuner: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles)) by bt878 #0 [sw]
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bash-2.05b#

Other than i2c (the tuner part), I don't know what the problem could be. Did you rescan the channels?

Edit** modprobe bttv without tuner=2

bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:00:0d.0, irq: 18, latency: 64, mmio: 0xefe00000
bttv0: detected: ATI TV Wonder/VE [card=64], PCI subsystem ID is 1002:0003
bttv0: using: ATI TV-Wonder VE [card=64,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
tuner: chip found at addr 0xc0 i2c-bus bt878 #0 [sw]
bttv0: using tuner=19
tuner: type set to 19 (Temic PAL* auto (4006 FN5)) by bt878 #0 [sw]
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 . ok

guardian653 07-18-2004 04:33 AM

I have the same card (running Slackware 10 with 2.4.26 stock) this is how I got it to work permanently.

Add this to the bottom of your /etc/modules.conf

Code:

options bttv card=64 tuner=2
Also if that doesn't work for some reason, try running tvtime as root. If you can run it, then you need to add yourself to the video group (it might complain about RTC if your not running as root, but it shouldn't effect you much if your on a fast machine)

jlschwab 07-18-2004 02:33 PM

Ok, thanks guys, I got it working.

I put the options bttv card64 tuner=2 in my /etc/modules.conf, on boot it doesnt say using tuner anything.
but if I rmmod bttv, and modprobe bttv tuner=2, it does properly detect NTSC on phillips as one of guys
got above and then does have my channels in correct order.

Thanks alot guys.
Very helpful.

-Jason


All times are GMT -5. The time now is 02:36 PM.