LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-26-2007, 07:30 PM   #1
waffe
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 69

Rep: Reputation: 15
btaudio not working


Hi,

I have an Avermedia 4 port capture card, it looks like this:
http://www.holm-teknik.dk/lx5004/lx5004.jpg

I am able to capture video on all for ports of this card, but I would like to be able to capture audio I have tried many things but nothing ever works. I am on ubuntu 2.6.20-15-generic

Here is a part of my lspci -v:

02:02.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture ( rev 11)
Flags: bus master, medium devsel, latency 132, IRQ 11
Memory at f0204000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2

02:02.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11 )
Flags: medium devsel, IRQ 11
Memory at f0205000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2

here is dmesg | grep bt
[ 67.703533] bttv: driver version 0.9.16 loaded
[ 67.703546] bttv: using 8 buffers with 2080k (520 pages) each for capture
[ 67.703554] bttv: Host bridge needs ETBF enabled.
[ 67.703687] bttv: Bt8xx card found (0).
[ 67.703742] bttv0: Bt878 (rev 17) at 0000:02:00.0, irq: 9, latency: 132, mmio: 0xf0200000
[ 67.703765] bttv0: using: AVerMedia TVPhone 98 [card=41,insmod option]
[ 67.703784] bttv0: enabling ETBF (430FX/VP3 compatibilty)
[ 67.703826] bttv0: gpio: en=00000000, out=00000000 in=008ff000 [init]
[ 67.738553] bttv0: Avermedia eeprom[0xffff]: tuner=Unknown type radio:yes remote control:yes
[ 67.738569] bttv0: using tuner=-1
[ 67.738578] bttv0: i2c: checking for MSP34xx @ 0x80... not found
[ 67.739456] bttv0: i2c: checking for TDA9875 @ 0xb0... not found
[ 67.740255] bttv0: i2c: checking for TDA7432 @ 0x8a... not found
[ 67.784353] bttv0: i2c: checking for TDA9887 @ 0x86... not found
[ 67.785273] bttv0: registered device video0
[ 67.785362] bttv0: registered device vbi0
[ 67.785455] bttv0: registered device radio0
[ 67.785484] bttv0: PLL: 28636363 => 35468950 .. ok
[ 67.816502] input: bttv IR (card=41) as /class/input/input4
[ 67.816651] bttv: Bt8xx card found (1).
[ 67.816708] bttv1: Bt878 (rev 17) at 0000:02:01.0, irq: 11, latency: 132, mmio: 0xf0202000
[ 67.816735] bttv1: using: AVerMedia TVPhone 98 [card=41,insmod option]
[ 67.816751] bttv1: enabling ETBF (430FX/VP3 compatibilty)
[ 67.816791] bttv1: gpio: en=00000000, out=00000000 in=008ffffd [init]
[ 67.857158] bttv1: Avermedia eeprom[0xffff]: tuner=Unknown type radio:yes remote control:yes
[ 67.857173] bttv1: using tuner=-1
[ 67.857182] bttv1: i2c: checking for MSP34xx @ 0x80... not found
[ 67.858062] bttv1: i2c: checking for TDA9875 @ 0xb0... not found
[ 67.858858] bttv1: i2c: checking for TDA7432 @ 0x8a... not found
[ 67.885930] bttv1: i2c: checking for TDA9887 @ 0x86... not found
[ 67.886914] bttv1: registered device video1
[ 67.887004] bttv1: registered device vbi1
[ 67.887099] bttv1: registered device radio1
[ 67.887129] bttv1: PLL: 28636363 => 35468950 .. ok
[ 67.916612] input: bttv IR (card=41) as /class/input/input5
[ 67.916759] bttv: Bt8xx card found (2).
[ 67.916814] bttv2: Bt878 (rev 17) at 0000:02:02.0, irq: 11, latency: 132, mmio: 0xf0204000
[ 67.916843] bttv2: using: AVerMedia TVPhone 98 [card=41,insmod option]
[ 67.916862] bttv2: enabling ETBF (430FX/VP3 compatibilty)
[ 67.916904] bttv2: gpio: en=00000000, out=00000000 in=008ffffe [init]
[ 67.957239] bttv2: Avermedia eeprom[0xffff]: tuner=Unknown type radio:yes remote control:yes
[ 67.957253] bttv2: using tuner=-1
[ 67.957262] bttv2: i2c: checking for MSP34xx @ 0x80... not found
[ 67.958091] bttv2: i2c: checking for TDA9875 @ 0xb0... not found
[ 67.958886] bttv2: i2c: checking for TDA7432 @ 0x8a... not found
[ 67.985886] bttv2: i2c: checking for TDA9887 @ 0x86... not found
[ 67.986873] bttv2: registered device video2
[ 67.986970] bttv2: registered device vbi2
[ 67.987103] bttv2: registered device radio2
[ 67.987133] bttv2: PLL: 28636363 => 35468950 .. ok
[ 68.017202] input: bttv IR (card=41) as /class/input/input6
[ 68.017346] bttv: Bt8xx card found (3).
[ 68.017402] bttv3: Bt878 (rev 17) at 0000:02:03.0, irq: 9, latency: 132, mmio: 0xf0206000
[ 68.017430] bttv3: using: AVerMedia TVPhone 98 [card=41,insmod option]
[ 68.017449] bttv3: enabling ETBF (430FX/VP3 compatibilty)
[ 68.017492] bttv3: gpio: en=00000000, out=00000000 in=008fffff [init]
[ 68.057812] bttv3: Avermedia eeprom[0xffff]: tuner=Unknown type radio:yes remote control:yes
[ 68.057827] bttv3: using tuner=-1
[ 68.057836] bttv3: i2c: checking for MSP34xx @ 0x80... not found
[ 68.058716] bttv3: i2c: checking for TDA9875 @ 0xb0... not found
[ 68.059511] bttv3: i2c: checking for TDA7432 @ 0x8a... not found
[ 68.087333] bttv3: i2c: checking for TDA9887 @ 0x86... not found
[ 68.088336] bttv3: registered device video3
[ 68.088427] bttv3: registered device vbi3
[ 68.088523] bttv3: registered device radio3
[ 68.088570] bttv3: PLL: 28636363 => 35468950 .. ok
[ 68.120487] input: bttv IR (card=41) as /class/input/input7
[ 68.210977] bt878: AUDIO driver version 0.0.0 loaded
[ 68.211063] bt878: Bt878 AUDIO function found (0).
[ 68.211102] bt878_probe: card id=[0xffffffff], Unknown card.
[ 68.211122] bt878: probe of 0000:02:00.1 failed with error -22
[ 68.211139] bt878: Bt878 AUDIO function found (0).
[ 68.211167] bt878_probe: card id=[0xffffffff], Unknown card.
[ 68.211183] bt878: probe of 0000:02:01.1 failed with error -22
[ 68.211199] bt878: Bt878 AUDIO function found (0).
[ 68.211227] bt878_probe: card id=[0xffffffff], Unknown card.
[ 68.211242] bt878: probe of 0000:02:02.1 failed with error -22
[ 68.211258] bt878: Bt878 AUDIO function found (0).
[ 68.211286] bt878_probe: card id=[0xffffffff], Unknown card.
[ 68.211301] bt878: probe of 0000:02:03.1 failed with error -22
[ 68.757383] Vortex: init.... <6>bttv IR (card=41): unknown key: key=0x23 raw=0x23 down=1
[ 68.915981] bttv IR (card=41): unknown key: key=0x23 raw=0x23 down=1
[ 69.015944] bttv IR (card=41): unknown key: key=0x23 raw=0x23 down=1
[ 69.119948] bttv IR (card=41): unknown key: key=0x23 raw=0x23 down=1


I have the error:
68.211122] bt878: probe of 0000:02:00.1 failed with error -22

and in my /dev I only have 1 dsp which is a generic sound card (line-in,mic,line-out) which works just fine and audio is set to alsa

But the I run this command:
modprobe -r snd-bt87x; modprobe snd-bt87x load_all=1

I now have dsp, dsp1-dsp4

I am then able to look at the each dsp with:

alsamixer -c

and

amixer -c

I set each card's capture to 100 and unmuted them.

And last I am trying to use sox to port the sound from dsp1-dsp4 to dsp like this:
sox -w -r 32000 -t ossdsp /dev/dsp2 -t ossdsp /dev/dsp

The above command seems to work but no audio is captured / coming through dsp.

I have read this may be a bug with linux/ubuntu but I'm not sure. Can anyone help.

Thanks,
waffe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SED - minor changes work - Larger doesn't (working and non working code included) Nimoy Programming 17 09-22-2007 04:34 PM
Fortemedia FM801 card not working under FC5 on Intel 845 but working with windows morningkiran Linux - Hardware 0 11-30-2006 07:57 AM
acpi nearly working IBM thinkpad R40e 2684HVG no Fn key working, throttling OK Emmanuel_uk Linux - Laptop and Netbook 2 05-31-2006 01:41 AM
BTaudio doesnt work slackware 9.1 bignester Linux - Hardware 0 01-13-2004 11:53 AM
cannot download files in mozilla -save dialog not working, galeon not working cmisip Linux - General 0 08-03-2003 03:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration