-   Linux - Hardware (
-   -   Brother printer not working after Gutsy upgrade (

camiguin 11-01-2007 04:20 AM

Brother printer not working after Gutsy upgrade
My printer Brother DCP 115C (it uses the MFC210C drivers, and is connected directly via USB) was working perfectly under Feisty. When I upgraded to Gutsy the printer stopped working, although the scanner part still works. In the computer everything looks normal, but nothing comes out of the printer. If I boot up in Windows the printer works, therefore printer and connections are OK. I have tried everything, such as reinstalling, fixing Apparmor with a complain command, disconnecting the USB for a long while, etc. Can anybody help?
Thank you.

bigrigdriver 11-01-2007 11:29 PM

It may be that your printer configuration file was deleted during the upgrade, and you need to set up the printer again.

It could also be that the cups ppd files were renamed with a extension such as .old, .save, or some other extension, and are not recognized.

Look in /etc/cups and /etc/cups/ppd for any such renamed configuration files, and rename them by removing the added extension to see if the printer works.

camiguin 11-03-2007 11:08 AM

USB connected printer not seen by system.
Thank you, Bigrigdriver, for your help. I have checked what you suggest without any success. Now, the symptoms have changed. After the last full
re-installation the problem is that in "System - Printers - Properties -
Interface" the URI listed is "usb:/dev/usb/lp0". I understand this is
wrong, and that it should be "//Brother/MFC-210C". But if I try to change it from root, I find that the first option, the correct one, namely "Local
printer" is greyed out, as if the system cannot recognize any connected
printer. Indeed, in the next step it says the usb is not a valid port. I checked this with KinfoCenter, USB devices, and the printer's presence is sensed, but only as "unknown", without identity as the other devices. In sum, the system does not recognize that there is a printer connected via USB.
Can you help? Thank you again.

poet_imp 11-03-2007 07:52 PM

Same problem with DCP-110c
I had the same problem with a different Brother driver and did get it to work. Here is what I did:

1) downloaded the LPR and CUPS driver for my printer


# ls -lrt *.deb
-rw-r--r-- 1 paul paul  12112 2007-11-03 13:53 cupswrapperDCP110C-1.0.2-3.i386.deb
-rw-r--r-- 1 paul paul 740018 2007-11-03 13:54 dcp110clpr-1.0.2-1.i386.deb

2) Deleted the printer that was defined to use that driver

3) Found the names of the currently installed packages


# dpkg -l | grep dcp
ii  cupswrapperdcp110c    1.0.0-1  Brother DCP110C CUPS wrapper driver
ii  dcp110clpr            1.0.2-1  Brother lpr Inkjet Printer Definitions

4) Removed the current software


# dpkg -r cupswrapperdcp110c dcp110clpr
(Reading database ... 141897 files and directories currently installed.)
Removing cupswrapperdcp110c ...
lpadmin: The printer or class was not found.
/etc/init.d/cups: Command not found.
Removing dcp110clpr ...

5) See what the status of the removal was.

# dpkg -l | grep dcp
rc  cupswrapperdcp110c  1.0.0-1  Brother DCP110C CUPS wrapper driver
rc  dcp110clpr          1.0.2-1  Brother lpr Inkjet Printer Definitions

6) Looks good, Purge the packages


# dpkg -P cupswrapperdcp110c dcp110clpr
(Reading database ... 141876 files and directories currently installed.)
Removing cupswrapperdcp110c ...
Purging configuration files for cupswrapperdcp110c ...
Removing dcp110clpr ...
Purging configuration files for dcp110clpr ...
dpkg - warning: while removing dcp110clpr, directory `/usr/local/Brother' not empty so not removed.

7) Verified that the directory it complained about was really empty and deleted it.


# rm -rf /usr/local/Brother
8) I read somewhere that I needed to clean up some dead soft links. So I found them and removed them.


# ls -al /usr/lib/libbrcompij2*
lrwxrwxrwx 1 root root 30 2007-04-30 17:21 /usr/lib/ -> /usr/lib/
lrwxrwxrwx 1 root root 30 2007-04-30 17:21 /usr/lib/ -> /usr/lib/
lrwxrwxrwx 1 root root 30 2007-04-30 17:21 /usr/lib/ -> /usr/lib/

# rm /usr/lib/libbrcompij2*

9) I installed the lpr package:

# dpkg -i --force-all dcp110clpr-1.0.2-1.i386.deb
Selecting previously deselected package dcp110clpr.
(Reading database ... 141876 files and directories currently installed.)
Unpacking dcp110clpr (from dcp110clpr-1.0.2-1.i386.deb) ...
Setting up dcp110clpr (1.0.2-1) ...

10) I installed the cups wrapper


# dpkg -i --force-all cupswrapperDCP110C-1.0.2-3.i386.deb
Selecting previously deselected package cupswrapperdcp110c.
(Reading database ... 141893 files and directories currently installed.)
Unpacking cupswrapperdcp110c (from cupswrapperDCP110C-1.0.2-3.i386.deb) ...
Setting up cupswrapperdcp110c (1.0.2-3) ...
rm -f /usr/lib/cups/filter/brlpdwrapperDCP110C
 * Restarting Common Unix Printing System: cupsd                                                                                                                [ OK ]

11) I defined a printer and tested it and it worked

I hope this works for you.

camiguin 11-04-2007 03:16 AM

Thank you, Poet Imp, for all your effort. I followed carefully your steps, substituting MFC210C (as per Brother's recommendation as replacement for my DCP115C) for your DCP110C. The results were similar to yours, but no joy at the end. I am still in the same situation, the system not recognising the identity of the usb-connected printer, and therefore not allowing it to be installed as local printer. Any ideas? Thanks again.

yvesvanbelle 11-05-2007 09:12 AM

Hello camiguin,

Try to use the CUPS web interface.

- first execute: $sudo adduser cupsys shadow
- next restart CUPS: $sudo /etc/init.d/cupsys restart
- open Firefox and type in as address: http://localhost:631
- remove the printer and the add it again

Best regards,


zeekoe 11-05-2007 01:25 PM

Try this:
sudo aa-complain cupsd

then try printing and check your kernel log (dmesg or /var/log/kern.log).
It might be the same as this:
(AppArmor seems to accidentally block third party print drivers)
In another launchpad bug, I saw the suggestion "apt-get install csh". You can just try this; you need csh and if you already have it installed it will tell you that.

Googling on "gutsy brother" took me there, and to this thread.

I have the DCP-115C too. Haven't tried the described solution yet, but perhaps it'll help you.

camiguin 11-08-2007 11:59 AM

Many thanks, Yves and Zeekoe. I tried your suggestions without success. I even tried them again after having received a cups update. But with all this I have defined the problem better: the system does see the printer, as shown in the outputs from KInfoCenter - USB devices, where the printer is shown as unknown (but it is a scanner-printer, therefore I understand this is OK):
Nº de serie #: BROA7F592130
Clase 0
Subclase 0
Protocolo 0
Versión USB 1.00
ID del vendedor 0x4f9
ID del producto 0x18c
Revisión 1.00
Velocidad 12 Mbit/s
Canales 0
Tamaño máximo del paquete 0

Also the output from usbview and other commands show the presence of a Brother device connected to a USB .
However, both the Genome-cups-manager (see screenshot2)


and the Kcontrol – printers (see screenshot1)


show exactly the same as if no printer was connected to a usb.
Therefore, the computer does see the printer, but the cups or other part of the printing system refuses to see the Brother printer. Any new ideas? Thanks again for the help.

camiguin 11-08-2007 03:39 PM

Just thought of enclosing the output from "printingbuginfo" in case it's useful for somebody interested in this vexing problem:

ProblemType: printingbuginfo v2.0: printingbug+localusb (
CupsConfiguredDevices: device for MFC210C: cups-pdf:/
CupsConfiguredPPDs: MFC210C: Brother MFC-210C CUPS v1.1
Date: Thu Nov 8 22:32:07 2007
DesktopEnvironment: KDE
DistroRelease: Ubuntu 7.10
EtcPapersize: a4
ii cupsys 1.3.2-1ubuntu7.1 Common UNIX Printing System(tm) - server
ii cupsys-driver-gutenprint 5.0.1-0ubuntu8 printer drivers for CUPS
ii foo2zjs 20070625-0ubuntu1 Support for printing to ZjStream-based printers
ii foomatic-db 20070919-0ubuntu3 OpenPrinting printer support - database
ii foomatic-db-engine 3.0.2-20070719-0ubuntu4 OpenPrinting printer support - programs
ii foomatic-db-gimp-print 5.0.1-0ubuntu8 OpenPrinting printer support - database for Gimp-Print printer d
ii foomatic-db-gutenprint 5.0.1-0ubuntu8 OpenPrinting printer support - database for Gutenprint printer d
ii foomatic-db-hpijs 20070813-0ubuntu1 OpenPrinting printer support - database for HPIJS driver
ii foomatic-filters 3.0.2-20070719-0ubuntu1 OpenPrinting printer support - filters
ii foomatic-gui 0.7.7 GNOME interface for configuring the Foomatic printer filter syst
ii ghostscript 8.61.dfsg.1~svn8187-0ubu The GPL Ghostscript PostScript/PDF interpreter
ii gnome-cups-manager 0.31-3ubuntu5 CUPS printer admin tool for GNOME
ii gs-common 8.61.dfsg.1~svn8187-0ubu Transitional package
ii gs-esp 8.61.dfsg.1~svn8187-0ubu Transitional package
ii gs-esp-x 8.61.dfsg.1~svn8187-0ubu Transitional package
ii hpijs 2.7.7+2.7.7.dfsg.1-0ubun HP Linux Printing and Imaging - gs IJS driver (hpijs)
ii ijsgutenprint 5.0.1-0ubuntu8 inkjet server - Ghostscript driver for Gutenprint
ii kdeprint 4:3.5.8-0ubuntu2 print system for KDE
ii libgnomeprint2.2-0 2.18.2-0ubuntu1 The GNOME 2.2 print architecture - runtime files
ii min12xxw 0.0.9-1build1 Printer driver for KonicaMinolta PagePro 1[234]xxW
ii openprinting-ppds 20070919-0ubuntu3 OpenPrinting printer support - PostScript PPD files
ii pnm2ppa 1.12-16 PPM to PPA converter
ii pxljr 1.1-0ubuntu1 Driver for HP's Color LaserJet 35xx/36xx color laser printers
ii splix Driver for Samsung's SPL2 (bw) and SPLc (color) laser printers
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8, LC_PAPER=en_GB.UTF-8
Uname: Linux fdp-ordenata 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux
UsbPrinterDevices: lrwxrwxrwx 1 root root 7 Nov 8 20:10 /dev/usblp0 -> usb/lp0
UsbPrinterIEEE1284Id: /dev/usblp0: Error: Permission denied: can't open '/dev/usblp0'
usblp 14080 0
usbcore 136088 9 option,usbserial,usblp,usbhid,usb_storage,libusual,ehci_hcd,uhci_hcd
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 002: ID 04f9:018c Brother Industries, Ltd
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 002: ID 1267:0201 Logic3 / SpectraVideo plc A4Tech SWOP-3 Mouse
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 12d1:1003
Bus 001 Device 001: ID 0000:0000

yvesvanbelle 11-09-2007 05:49 AM

There are problems when using 3rd party printer drivers in Ubuntu 7.10 (Gutsy Gibbon). The problem is caused by AppArmor, see links below:
The solution is to exectute the following command "sudo aa-complain cupsd", again see below:

The command aa-complain detects violations of AppArmor profile rules, such as the profiled program accessing files not permitted by the profile. The violations are permitted, but logged.

Best regards,


camiguin 11-09-2007 09:01 AM

Thanks, Yves. I had already tried that approach, and I did again on receiving your message, and I'm sorry to report that it does not work. I think the problem has a different origin, because with or without cups in complain mode, the printing system does not "see" the printer as local, connected via usb. As a result it is as if no printer was connected at all, and I cannot even configure it, let alone printing. If I try to configure it in System - Admin - Printers - Properties - Interface in administrator mode, the "local" option is greyed, therefore unusable. Any ideas along these lines? Warm regards

yvesvanbelle 11-10-2007 05:24 AM

I have a DCP-310CN at the office, this is a DCP-115 with network. I will try to configure it on monday. Once it works i will tell you how i did it.

Best regards,


yvesvanbelle 11-12-2007 04:54 AM

Hello camiguin,

I installed the DCP-310C with USB on my newly installed Ubuntu 7.10 (Gutsy Gibbon) and it worked. Here is how i did it:

from the command line:
sudo apt-get install csh
sudo aa-complain cupsd

Then i downloaded the latest debs on my desktop:

To install the debs i clicked first on mfc210clpr-1.0.2-1.i386.deb to have it installed with GDebi Package Installer, next i did the same thing with the cupswrapperMFC210C-1.0.2-3.i386.deb.

I went to printing, selected the MFC-210C a did print a test page. It was a bit slow, but it worked.

Best regards,


camiguin 11-12-2007 07:35 AM

Thank you, Yves. I was half expecting that you would succeed, as you did. I have repeated your process (which is the same I have followed all along) after de-installing the printer, but I am stuck in the same place: the printer is not seen by either Gnome-cups manager or Kcontrol - Printers, but it is seen by lsusb and KInfoCenter. I realize now I have a problem with my computer, which is not generic of Gutsy (although it started on moving to Gutsy). The difficulty is that I don have the foggiest idea of where to look for faulty or missing instructions or programs. Does anybody know what part of the system looks for local printers?
Thank you again for your patience.

camiguin 11-12-2007 05:12 PM

Browsing through different fora I found a solution to the problem, albeit incomplete: with the command
$sudo chmod a+rwx /dev/usb*
(which I don't have the foggiest idea of what it does), suddenly the printer becomes visible to "lpinfo -v", the option "local" becomes possible for installing printers, and indeed once installed the printer prints. Problems: first, everything becomes undone on rebooting, so every time I switch on I have to go through the whole process; second, less important, but maybe significant, the installed printers, whether working or not, are visible to Kcontrol only when I chose root mode. Any help for the final push? Many thanks

All times are GMT -5. The time now is 09:03 PM.