-   Linux - Hardware (
-   -   Brother MFC420CN suddenly stops working (

NosLycn 06-17-2006 04:43 PM

Brother MFC420CN suddenly stops working
Howdy friends!

Here's the skinny on what's going on here:

I didn't really do anything. I just continued using my fully functioning Debian (unstable) system wonderfully. I tried installing a mail server and failed miserably. Still, that was an extra so I'm not concerned at all about that. What concerns me is that my printer (once functioning perfectly) now has some odd little quirks.

It's a brother mfc420cn, so I install the drivers from their site. It has two sets of drivers for the local printing (and more for fax, which isn't of any concern at the moment). First, the printer wouldn't print. I come to find out that cups for some reason suddenly isn't installed. This is weird, so I install cups again, and lpr again, using my handy dandy apt-get install lpr cupsys. Suddenly it works, but not completely. It works through cups, but not through console using:

lpr -P MFC420CN <filename>

So, I reinstall the lpr driver and it suddenly works in lpr (but not in cups). Well, I say it works, but it is cutting off the top of every page I print. Since this is "working", I reinstall the cupswrapper driver. lpd is shut off by the driver, /etc/printcap is overwritten by cupsd, and I can't print from lpr. I also can't print from cups. In fact, the whole cups server appears to not be running. But, it says it is running.

So, my question to all of you is:

What do you think is wrong with this system?

NosLycn 06-17-2006 06:38 PM

Okay. I have both lpr and cups working, except that lpr still is clipping the top off each page. It acts as though it is set to A4 (which it may be) and it just prints the bottom up to the point where it would normally cut off for a letter, except that it starts printing at the top. When I changed the setting to letter with brprintconfij2, it just functions to cut more from the top of the page. This is rather troubling. Many applications prefer to use lpr to the other printing options. (like the program that properly displays my resume) If anyone could assist in resolving this issue, which could be related, it would be quite helpful.

NosLycn 06-19-2006 11:18 PM

By using nothing more than magic, I managed to get this working. Apparently there is a program called a2ps which converts printed documents to postscript documents for this printer to print. a2ps had a config file that was pointing to a medium of libpaper. I changed libpaper to letter and it worked. That config file was /etc/a2ps-site.cfg and I changed --medium=libpaper to --medium=letter. Thanks for the help. I hope that this helps someone else.

All times are GMT -5. The time now is 09:33 PM.