-   Linux - Hardware (
-   -   Brother MFC-5100c printer driver (

kkaliek 08-23-2002 08:35 PM

Brother MFC-5100c printer driver
I have been trying desperately to get my Brother priner to work with Linux and have gotten nowhere. I am using Mandrake 8.2, but have even tried using Caldera 3.2 and Red Hat 7.0 and was not able to print. I have tried hooking an Epson printer up to the computer and it prints with no problem so I think it must be the printer driver (I know the printer itself is fine because it prints under windows). I do not care at all about getting the scanner to work, any sign of life -- even gobblygook, would be welcome!!! Here is the problem as far as I can tell:

Almost every time I try a new driver (I've tried all of CUPS, LPRNGs and PDQ's Brother MFC's and a couple of HL's) my printer says "RECEIVING DATA" but then displays the time and date again, making no noises or motions to begin printing. lpq tells me that the job has printed, and I haven't been able to find any errors anywhere!

Here are some lines from the /var/log/messages if that helps:

Aug 23 20:50:46 sunai kernel: lp0: compatibility mode
Aug 23 20:50:48 sunai kernel: lp0: compatibility mode
Aug 23 20:50:48 sunai kernel: lp0: compatibility mode
Aug 23 20:51:12 sunai kernel: lp0: using parport0 (polling).
Aug 23 20:51:42 sunai printerdrake[6795]: running: foomatic-configure -q -s cups -n Printer -c file:/dev/lp0 -p 62528 -d hl7x0 -N Brother MFC-5100C -L -o PageSize=Letter
Aug 23 20:52:22 sunai kernel: lp0: compatibility mode
Aug 23 21:11:42 sunai kernel: lp0: compatibility mode

Because the printer says "RECEIVING DATA" but never prints, I thought it might be that I just need to send an eof message to the printer, but I can't find where to do it! I can program a bit of C/C++ if you could tell me what files to look for...I'm even willing to try writing a driver if someone could give me pointers. I've never used interrupts or interfaced with hardware before, but I think if I knew what file and basic functions I need to try, I might be able to modify a current brother driver. I've looked at some paport and CUPS documentation but there seem to be so many different files to use and ways to do things that I'm having trouble figuring out exactly how and where I'd attempt to write a driver.

I thank you very much for any help you can give!

MiscGeek 07-03-2003 08:45 PM


Welcome to LQ!

Unfortunately I don't have an answer to your question. I'm experiencing the same symptoms with a Brother MFC-4420C.

The odd thing is I don't have the MFC connected directly to the my Linux box. It's shared on a W2K box. I've tried using just the Raw Print Queue option, PostScript Driver, etc... with no luck what so ever :(

The printer says "Receving Data" but never prints.

If I get any further with this I'll post back here. Maybe it will you with your problem.

Good Luck!


All times are GMT -5. The time now is 12:13 AM.