LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Broadcom 802.11g Network Adapter - intall on Slackware v12.1 (https://www.linuxquestions.org/questions/linux-hardware-18/broadcom-802-11g-network-adapter-intall-on-slackware-v12-1-a-661823/)

Bonny 08-10-2008 01:47 PM

Broadcom 802.11g Network Adapter - intall on Slackware v12.1
 
Hello everyone.

I am a new user of Slackware Linux (and all Linux, in fact), and have troubles installing my Broadcom 802.11g Network Adapter. I have absolutely NO idea as to how to connect to a wireless network, and have huge difficulties understanding WHY it doesn't work.

I have tried to google it (google IS your friend), but it did not help.

Could anyone give me a hint as to how to make it work?

PS: I am looking to connect to ANY wireless networks whatsoever, and I have one that is surely in range of my laptop (Acer Ferrari AMD Turon 64)

Sorry if I didn't include enough detail, but I don't know more about it myself :D --- it's awful to feel like a n00b, and I hate that feeling.

MS3FGX 08-10-2008 02:25 PM

What type of adapter is this? USB, PCI, PCMCIA?

Do you know what chipset it is using? Use lsusb and lspci to find device information for components plugged into the respective buses. Or if you know the model number, that would be a start.

Bonny 08-10-2008 02:48 PM

when I issued the 'lsusb' command, I figured out that it is NOT usb, but it is an integrated wireless network adapter.

When I issued the 'lspci' command, it returned the following:

Ethernet Controller: Broadcom Corporation Netlink BCM5789 Gigabit Ethernet PCI Express
Network Controller: Broadcom Corporation Netlink BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller.

Therefore, I guess it is a PCI. Vista returns the following info about it:
Name: [00000005] Broadcom 802.11g Network Adapter
Adapter Type: Ethernet 802.3
Product Type: Broadcom 802.11g Network Adapter

I don't know how to get more information on the model :-?

and no, I don't know what chipset it is using :(

Bonny 08-11-2008 04:35 AM

can anyone help me, please?

MS3FGX 08-11-2008 11:05 AM

You hardware is supported by the b43 drivers. The driver itself should be included in Slackware as it is part of the mainline kernel, but the Broadcom WLAN devices need copyrighted firmware on top of the driver to operate, which cannot be included in the distribution.

This section of the site details the installation of device-specific firmware installation. Following that part should get your hardware working.

Failing that, your other option would be to use ndiswrapper. There is a guide here on LQ which details the installation of the drivers through ndiswrapper. It is a bit old, but the general process has not changed.

Bonny 08-18-2008 04:53 PM

Thank you for the information. I have installed the firmware and I have installed the drivers. I have (finally) managed to activate the wlan, but I am stuck once again.

I turn my wlan interface on using: ifconfig wlan0 up
I search for wireless networks: iwlist scan or iwlist wlan0 scan

The scan does find my network:

-----------------------------------------------
Cell 01 - Address: 00:01:E3:F2:39:C5
ESSID:"TiscaliF239C5"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=48/100 Signal level=-69 dBm Noise level=-72 dBm
Encryption key: on
IE: WPA Version1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
Bit Rates: 1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s;
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s;
48 Mb/s; 54 Mb/s;
Extra:tsf=00000001d9aa0fd0

-----------------------------------------------

But how do I connect to it?:) I have tried to modify '/etc/rc.d/rc.wireless.conf' or '/etc/rc.d/rc.inet1.conf', but it doesn't work. Have you got any suggestions as to how to make it work?

Many thanks

forum1793 08-18-2008 05:50 PM

I did not have same wireless NIC as yours but I was only able to get mine connecting to my router using wicd (the Robbie Workman version). But I was also using wpa2. Maybe if using wep making changes to rc.inet1.conf might work. I had wpa_supplicant working also but I can't remember if I needed it for wicd (its on a different machine or I would check).

Bonny 08-19-2008 09:39 AM

I have downloaded the wicd client from where you told me and managed (finally) to untar the files. I have a folder called 'wicd-1.5.1-noarch-1_rlw'. However, I didn't figure out how to install it. I have tried running the file 'doinstall.sh' from the install folder (using 'sh doinstall.sh'), but it doesn't seem to be installed. I have tried using /etc/rc.d/rc.wicd start, but the file is missing... I have tried cd-ing into the folder and then type make or install, but it, once again, doesn't work.

It feels really bad to be a newb, lol. Could anyone help me install wicd please?:) Or find another way to connect to my wireless network? ;;) cheers

Hangdog42 08-19-2008 11:49 AM

Quote:

I didn't figure out how to install it. I have tried running the file 'doinstall.sh' from the install folder (using 'sh doinstall.sh'), but it doesn't seem to be installed.
The file fourm1793 linked to is a Slacware package that you install with either pkgtool or installpkg. If you didn't do that, then nothing else beyond it works. You could also do the Slackbuild approach and since the Slackbuild script on Slackbuild.org is also from Robby Workman, it should do the same thing. There are also a few instructions in that link I just posted. I've been using wicd a lot lately, and it works very well with Slackware.

Bonny 08-19-2008 06:45 PM

Sorry Hangdog, but I don't figure out what you are trying to tell me :D. I am really sorry, it's hard to be a newb!!!

When you say that I need to use pkgtoolor installpkg, which package do I need to apply it to? it sais it needs a .tgz file, and I can't find any files with that extension.

I have looked at the Slackbuild approach, but I don't have the file '/etc/rc.d/rc.wicd'. . .

I'm stuck, and I read your posts :(

MS3FGX 08-19-2008 07:02 PM

You run installpkg against the .tgz file you downloaded from forum1793's post. You aren't supposed to actually extract them, it is an installable binary package.

Bonny 08-19-2008 07:28 PM

Now I feel like an idiot.... thank you, I have managed to install Wicd Manager. I can even see my network!!! However, after I set up the encryption method (WPA1/2) and click connect, it just doesn't connect....
After I click CONNECT, I can see at the bottom the following, in order:

Putting interface down
Generating Psk
Validating authentication
And then, suddenly, "Not connected" stays there.

What could be wrong this time? :(

Bonny 08-20-2008 06:15 AM

SOLVED! Thanks a lot everyone, and sorry for being such a noob :)

Hangdog42 08-20-2008 07:12 AM

Quote:

Originally Posted by Bonny (Post 3253627)
SOLVED! Thanks a lot everyone, and sorry for being such a noob :)

Would you be a kind soul and tell us what you did to solve it? Someone will find this thread and having the solution would be invaluable to them!

And no need to apologize for being new to this. Personally, I learn new things here every single day. That is why I keep coming back.

Bonny 08-20-2008 10:41 AM

(SOLVED) Broadcom 802.11g Network Adapter - install on Slackware v12.1 (+wicd)
 
Ok, let's see.. how the hell did I do it in the first place?? :))

Firstly, I installed Slackware Linux v12.1 (of course).

1. Then, without editing any files (such as /etc/rc.d/rc.wireless.conf), I installed the firmware for my WLAN Adapter. Clicking here will teach you how to install your device-specific firmware. Since I have found it quite difficult (as a REAL NOOB) to install it from there, I will outline the main points and will show exactly what I did to install the firmware:
1a. Download Fwcutter v011 and place it in a directory. For the sake of this explanation, let's say you will place it in the /root/Fwcutter directory.
1b. Cd into the "/root/Fwcutter" directory ("cd /root/Fwcutter") -- if you don't have that directory, use 'mkdir /root/Fwcutter' and you will have it :)
1c. Untar Fwcutter using this command: 'tar xjf b43-fwcutter-011.tar.bz2'
1d. Cd into the new extracted directory: 'cd b43-fwcutter-011'
1e. Install the firmware: 'make'
1f. Exit the directory: 'cd ..'

Voila! Now you have your tool (Fwcutter) that will enable you to install the firmware needed.

2. Download the Broadcom's Proprietary Driver (v4.80.53.0). This works, however only on the following Linux Kernels: Linux-2.6.24, including 2.6.24-rcX and 2.6.24.Y. Check out your Kernel Version using the command 'uname -r'. If you have a different version, download a different driver from here.
2a. Untar it: 'tar xjf broadcom-wl-4.80.53.0.tar.bz2'. (into a folder like you created for fwcutter)
2b. Cd into the folder: 'cd broadcom-wl-4.80.53.0/kmod'
2c. Then just apply this command: 'sudo ../../b43-fwcutter-011/b43-fwcutter -w /lib/firmware wl_apsta.o'

Voila! Now you have your Broadcom Proprietary Drivers installed. But you've not finished everything. I would recommend issuing a restart to your system - I am not sure it's needed, but I would advise you to.

3. Now you need a WORKING tool to connect to your wireless networks. As advised by Forum 1793, I used Wicd Manager.
3a. Download the file somewhere on your computer (preferably somewhere where you won't forget where it is, such as /root/wicd).
3b. Cd into the folder where you can find the downloaded file
3c. Issue the 'pkgtool' command and select its first option. Select the package you have just downloaded and let it install it.
3d. voila once again :) I don't think you need to perform any other tasks yet, so just RESTART YOUR MACHINE ('shutdown -r now')

I don't know if it is going to connect automatically, but after logging in again, just go into X by using 'startx'. There, your Wicd Manager should have appeared in the taskbar or in the KMenu. You can learn using wicd using the 'wicd --help' command, but I would recommend starting x and configuring its graphical interface. There, you should find the wireless networks in range and everything you need will be there.

Thank you everyone for helping me, and, once again, sorry for being SUCH a noob. I hope there will be people benefitting from this LONG (yet complete -- I hope) walkthrough. I hope you will spend much less time fixing your wireless network than me.

Cheers


All times are GMT -5. The time now is 04:17 PM.