LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Bringing up interface eth0.... failed (https://www.linuxquestions.org/questions/linux-hardware-18/bringing-up-interface-eth0-failed-83858/)

synecdoche 08-20-2003 12:24 PM

Bringing up interface eth0.... failed
 
All of a sudden, when my RH9 box boots up, it can't seem to bring up eth0. It gets to that stage, pauses for a LONG time, then eventually says [FAILED].

I don't know what could have caused this. It was working fine. Then, at some point, I rebooted, and after that, nothing. I've tried rebooting again to see if it was a one time only dealie, but no such luck. It continues to fail to bring up eth0.

Does anybody have any ideas about how this might have happened, or better yet, how to fix it? I tried using RH's graphical network tools to activate the network but all of that fails as well.

Thanks,
Dave

crabboy 08-20-2003 12:29 PM

How is the interface configured? DHCP or static IP? It sounds like the dhcpcd process is trying to find a dhcp server (long pause) to set the IP address and can't find one. This would be one reason why it does not start. I'd start by trying to run the eht0 init script from the command line and watch the output so you can see where it fails.

synecdoche 08-20-2003 01:39 PM

It his DHCP... Well it seems to be working now, though I am not sure why.

I am still getting this error though:
Starting lm_sensors: i2c-core.o: i2c core module
i2c-proc.o version 2.6.1 (20010825)
Starting up sensors: can't access lproc file /proc/sys/dev/sensors/chips or /proc/bus/i2c unreadable

(Then there is something else too but it went by too fast for me to write it down).

-dave


All times are GMT -5. The time now is 03:13 PM.