-   Linux - Hardware (
-   -   Boot from Verbatim USB flash drive? Not on a Dell Dimension 4600! (

taylorkh 06-20-2011 02:50 PM

Boot from Verbatim USB flash drive? Not on a Dell Dimension 4600!
Here is a strange one... I have been using g4l to do cold backups of my OS partitions for a LONG time. I finally decided to configure a boot USB flash drive instead of a CD for this purpose. Using the EXCELLENT instructions on this page I configured a Lexar 1 GB Firefly drive and have used it for some time. When a newer version of g4l came out I decided to build another boot flash drive using a Verbatim 1GB drive. I followed the same instructions and...

The Verbatim flash drive will boot my Dell Studio XPS and my Dell Latitude 2100 netbook. It will NOT boot either of my Dell Dimension 4600s. The Dimension 4600s respond with a message "Missing operating system" when I try to boot from the Verbatim drive. The Firefly works on all machines and I configured Kingston 1GB and 2GB Data Travelers which also work on all machines.

Any ideas?



wingman358 06-20-2011 04:45 PM

Do you absolutely need to use the verbatim drive? in the worst case, you could revert to the old version of g4l

thorkelljarl 06-20-2011 04:46 PM

An idea...

Your BIOS does not natively recognize the Verbatim USB flash device as a valid device for booting.

On my system I can boot from a USB flash(Verbatim), but have to select it as a USB-HDD on the one-time-boot menu at POST. Have you tried all the possible BIOS boot sequence settings and tried all the one-time-boot choices?

Have you set a boot flag on the partition table?

jefro 06-20-2011 09:06 PM

I find that the bios plays a big part.

Do a full power off. Plug in usb. Boot to bios. See where the usb fits. It may show in hard drive order or removable order.

If the usb boots in one then it is good to some point. Only some old systems had issues with syslinux and isolinux but I can't beleive one could boot usb to such systems.

taylorkh 06-22-2011 05:15 PM

I don't have to use the Verbatim. It just happened to be the next one I grabbed when I was making a new g4l boot drive.

I manually select the boot device by pressing F12 during POST and navigating to the USB flash drive.

Fdisk shows the boot flag is set on the partition on the flash drive.

I disconnected everything from the PC and popped the button battery to reset the BIOS. No difference.

Thanks for the replies. I have plenty of other flash drives. I will relegate the Verbatim to some other use.


thorkelljarl 06-23-2011 05:22 AM

Not USB flash...

Although it is not critical for you, you might note that my system only recognizes any Verbatim USB flash sticks I use as a USB-HDD, that is as a hard disk. It is either listed on the one-time-boot menu as USB-HDD or listed on a sub-menu with any other HDD present.

This may be a condition imposed by my BIOS, but it is as that I suggested you try to boot your Verbatim.

taylorkh 06-23-2011 08:08 PM

Thanks thorkelljarl,

The options I have on the boot menu are:

2-SATA Primary Drive
3-Hard-Disk Drive C:
5-USB Flash Drive
6-System Setup
7-IDE Drive Diagnostics
8-Boot Utility Partition

These do not change regardless of what is plugged in to the USP ports. Options 1, 2 and 3 point to the same device. 7 and 8 are no longer on the machine since the factory image hard drive was reformatted (well actually replaced).

My newer machines report the identity of the USB flash drive as Verbatim drive or Lexar Firefly etc. I guess they are "improved."

Next time I have a monitor connected to my PowerEdge server I will see it it can boot from the Verbatim. It is about the same vintage as the Dimension 4600s.


thorkelljarl 06-24-2011 01:57 PM

And thank you...

I can see that you havn't a choice that gives you a chance at opening that Verbatim. Some BIOSes do, some BIOSes don't.

taylorkh 07-05-2011 08:58 AM

Well I guess I will just relegate the Verbatim drive to the junk pile with my other obsolete stuff. It was the first 1 GB flash drive I purchased. Got it on sale for $10 with a coupon and a rebate! About a year before a co-worker got a 1 GB flash drive from Dell for $41 after rebate. He thought it was a heck of deal. He spend a lot of time on the phone with Dell as it was out of stock and he was concerned about getting it in time to apply for the rebate. Today I don't think your could even find a flash drive that small.


All times are GMT -5. The time now is 12:45 PM.