LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   bonding 2 NICs CentOS 6.4 question (http://www.linuxquestions.org/questions/showthread.php?t=4175475640)

lleb 09-02-2013 09:06 PM

bonding 2 NICs CentOS 6.4 question
 
I have been playing around with my new MB and as I now have 2x 10/100/1000 NICs (one on board and one PCIe expansion) i figured I'd muck around with bonding.

Rather simple to setup once I found the current path for modbprobe. All of the guides out there in google land point to /etc/modprobde.conf <bad file, it is depreciated and not used> after some digging around I was able to find a document from RH, love their documentation for the most part, that had the correct process and path:

Quote:

For a channel bonding interface to be valid, the kernel module must be loaded. To ensure that the module is loaded when the channel bonding interface is brought up, create a new file as root named /bonding/.conf in the /etc/modprobe.d/ directory. Note that you can name this file anything you like as long as it ends with a .conf extension. Insert the following line in this new file:
very nice to have the correct information. From what I have read bonding is supposed to drastically increase performance as well as create redundancy. Does anyone out there in leap have experience with this and can you confirm these "assumptions"

I just did a simple and basic bonding but am more then willing to learn how to adjust for better performance.

i did the following:
Code:

[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth3
DEVICE="eth3"
USERCTL="no"
ONBOOT="yes"
MASTER="bond0"
SLAVE="yes"
BOOTPROTO="none"

##############################
## Original eth3 file below ##
##############################

#DEVICE="eth3"
#TYPE="Ethernet"
#HWADDR=D4:3D:7E:9B:6E:10
#NAME="System eth3"
#ONBOOT="yes"
    #BOOTPROTO="dhcp"
#BOOTPROTO="static"
#NM_CONTROLLED="no"
#IPADDR=192.168.2.125
#NETMASK=255.255.255.0
#USERCTL="no"
    #DEFROUTE=yes
    #PEERROUTES=yes
    #PEERDNS=yes
#IPV4_FAILURE_FATAL=yes
#IPV6INIT=no


with eth4 identical except for 4 instead of 3... Left the older configuration in the file so that when I come to an other install fest I can break the bonding (if i can figure that out) as bonding does not support DHCP, from what ive read.

Code:

[root@centos ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
IPADDR=192.168.2.125
NETWORK=192.168.2.0
NETMASK=255.255.255.0
USERCTL=no
BOOTPROTO=none
ONBOOT=yes

and here was the rub, the part the howto guides online from google search were off:
Code:

[root@centos ~]# cat /etc/modprobe.d/bonding.conf
alias bond0 bonding options bond0 mode=balance-alb miimon=100


https://www.centos.org/docs/4/html/r...nterfaces.html<way old as this is for RHEL4>
http://www.cyberciti.biz/tips/linux-...interface.html

the cyberciti.biz is supposed to work under RHEL6, I can tell you it is still pointing to the wrong location for /etc/modprobe.conf....

https://access.redhat.com/site/docum...aces-chan.html

This has the correct location. sadly it is a bit sparse in its directions.


All times are GMT -5. The time now is 08:56 AM.