-   Linux - Hardware (
-   -   Black screen when trying to install ATI drivers on Radeon x1600 (

vangelis 05-23-2006 04:31 AM

Black screen when trying to install ATI drivers on Radeon x1600
I love linux, I love Nvidia (in linux) why did I have to move to ATI?

Recently I bought a radeon x1600 512Mb pci express 16 (taken from lspci) and the problem here is
that I cannot enable 3D accelaration(very common as I browsed the forum).
The ATI installation guide is very poor, I gotta say that users across the internet have made better
guides step by step for many distros.

There are two ways of installing the ATI drivers.

One, is using the installer directly. But that in that way I found at the fglrx install log that it cannot compile the
module. I have the kernel sources, gcc and make installed. I found also somewhere in the suse forums of
tweaking a .c file right before the installer starts to add a line including something about the kernel version.
Ofcourse since there is an error here there's no meaning on proceeding(although I tried)

Second, is to build an rpm package out of the installer for your distro-arch and install it.
then go to init 3 and do aticonfig --initial --input=/etc/X11/xorg.conf
Here is the problem. After that command I edit my xorg.conf file and it's all messed up
(I cannot right now to post it,on work) It has 2 sections of Device, Screen, Monitor one for the old xorg.file for
the vesa driver and one for aticonfig.
I saw other example xorg files and these sections were fixed.
I run sax2 -r -m 0=fglrx and then when sax2 tries to load the xserver the my screen goes black.
After that I cannot do anything the keyboard is working though.The next step is to reboot but since it's not
working it's pointless.

After that I tried many things, either by loading the module fglrx with modprobe, nothing.
I tied to comment # the duplicated settings in xorg file for the vesa drivers but still nothing. The system hangs
when I run the command sax2 -r -m 0=fglrx.
I tried also to change the dri setting from 0660 to 0666, still nothing.

I've read on the ATI site that the radeon x1XXX 512mb cards have problem with some motherboards and they are
working on it for the next release of the driver.

I really wan't to believe that there is something wrong with what I am doing and it's not the grapchics card-motherboard

I can post my xorg file if anyone want's to check it.

PS. I don't know if it helps I have an AMD64 but installed the 32bit version of SuSE 10.1 due to that I cannot
operate my dsl modem on the 64bit suse version and for that reason I am using the x86 rpm
and not x86_64 ( I don't think I can extract a x86_84 rpm)

RobNyc 05-24-2006 12:43 AM

I have a X1600 Pro. Which I only found Ubuntu Dapper to handle the best. I've tried others that I like except Gentoo/Phaeronix/Kororaa which I'm sure will handle good. Lately I just use OSX86 and Windows(for games only). Frugalware is currently installed and I cant get 3d/ati/fglrx to work properly, so its on vesa. It works on vesa with anything . FC5 wouldn't work correctly with fglrx either after a reboot, PCLinuxOS was acting weird. Only Ubuntu Dapper was the sucess.

sarahan 06-10-2006 11:27 PM

check this link
Hi, try this:

Post #4

I've got an X1900, and was experiencing similar problems. This cleared them up.

good luck.

vangelis 06-11-2006 04:12 AM

Thanks for your reply but that also didn't work for me.
At /var/log/SaX.log it gives me all the time the same message no matter what I do

(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 720x400@88Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@87Hz (interlaced)
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1152x870@75Hz
(II) fglrx(0): Manufacturer's mask: 70
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1280 vsize 960 refresh: 60 vid: 16513
(II) fglrx(0): #1: hsize: 1152 vsize 864 refresh: 70 vid: 19057
(II) fglrx(0): #2: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
(II) fglrx(0): #3: hsize: 1152 vsize 864 refresh: 75 vid: 20337
(II) fglrx(0): Serial No:
(II) fglrx(0): 2[F
(II) fglrx(0): End of Display1 EDID data --------------------
(WW) fglrx(0): Specified desktop setup not supported: 8

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

0: /usr/sbin/xw(xf86SigHandler+0x7e) [0x44866e]
1: /lib64/ [0x2b81fbedeb20]
2: /lib64/ [0x2b81fbf22b72]
3: /usr/X11R6/lib64/modules/ [0x2b81fe36bee9]
4: /usr/X11R6/lib64/modules/drivers/ [0x2b81fd306a9c]
5: /usr/X11R6/lib64/modules/drivers/ [0x2b81fd304771]
6: /usr/X11R6/lib64/modules/drivers/ [0x2b81fd3062b2]
7: /usr/X11R6/lib64/modules/drivers/ [0x2b81fd2ddcd6]
8: /usr/sbin/xw(InitOutput+0x9ec) [0x43251c]
9: /usr/sbin/xw(main+0x21a) [0x49512a]
10: /lib64/ [0x2b81fbecc154]
11: /usr/sbin/xw [0x430cc9]

Fatal server error:
Caught signal 11. Server aborting
I have checked and corrected my monitor frequencies but still..

vangelis 10-22-2006 03:12 PM

It was ATI's drivers problem after all
At the last 2 versions they have at the section known issues in release notes

Loading the XVideo Extension on 64-bit Xorg 6.9+ systems causes the X Server to segfault on launch with ATI Radeon X1K products. Further details and the workaround can be found in topic number 737-22837

Exactly what I happen to have 6 months and was spamming the web about it..

So.. I'll be waiting for the next driver release

RobNyc 11-25-2006 01:18 AM

Yea ATI drivers sucks .. it sucks for us
no more money for ati !!!

Javve 03-25-2008 12:18 AM

This worked for me.

In: /etc/X11/gdm.conf

I had to add this line:

I also made sure in: /etc/kde/kdm/kdmrc

This statement was as follows:
Under section: [X-:*-Core]

I am using PCLInuxOS built from the minime 2008, it was the ATI driver install off of their site that caused me to get the black screen. I installed the latest driver as of March 25, 2008.

All times are GMT -5. The time now is 02:29 PM.