LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   BIOS not recognizing IDE devices (https://www.linuxquestions.org/questions/linux-hardware-18/bios-not-recognizing-ide-devices-275525/)

snakeo2 01-08-2005 06:58 PM

BIOS not recognizing IDE devices
 
this is not a linux or windows question, rather a hardware question. i recently bought different components to build my box. i bouth an intel D915PBL MOBO/ PENTIUM 4 FSB 800 MHZ/512 MB DDR2/ 200GB SEAGATE ATA HD/FLOPPY DRIVE/CD-ROM/CDRW/ ATI RADEON X600 PCI EXPRESS. The first problem: Mobo only has one IDE Connector. Fine , I went out and bought a PCI IDE Adapter to be able to connect other IDE devices. after putting everything together, bios wont recognize all IDE devices. First i tried to connect the cd-rom and hard drive on the same cable as master and slave respectively and plugged into the onboard IDE connector. after booting the box, BIOS doesn see any of them. if i unplugg either one (cd-rom or hard drive) bios will see the one that remains connected. then i tried connecting cd-rom/ cd-rw to the pci ide adapter and the hard drive to the onboard IDE connector. after booting box, bios only sees hard drive. Please note that all devices are configured to cable select. this is so frustrating. Can anyone suggest any solutions to this problem , thanks in advance

Peacedog 01-08-2005 07:29 PM

The first thing I'd try is actually setting the jumpers on all of the devices to either master or slave rather than cable select. I've seen many problems from using the cable select option.

The next thing I'd look at is bios upgrades that are available. Hope this helps.
good luck.

snakeo2 01-09-2005 02:27 PM

thanks dog, your suggestion did the trick

Peacedog 01-09-2005 06:17 PM

Glad to be of service.
good luck.


All times are GMT -5. The time now is 09:56 PM.