-   Linux - Hardware (
-   -   BIOS detects correct HD size but linux doesnt? (

darcon3k 07-21-2004 01:26 AM

BIOS detects correct HD size but linux doesnt?
I'm trying to install clarkconnect on an old 13GB Maxtor HD. The BIOS, partion magic, and windows detect the size correctly. But the clarkconnect (based on redhat) installer only detects it as a 2GB drive. At first I thought something must be messed up with the partitioning software on clarkconnect so I popped in knoppix 3.4 and fired up qtparted.... exact same problem. Anyone have any ideas? All the other topics I found were about BIOS showing wrong size and linux detecting the size correctly but my problem is the exact opposite :(

fireicer 07-21-2004 02:27 AM

that sounds like the software dont support the block allocation or LBA. bios's have problems detecting over 32gig but sometimes software can not translate the part table correctly and allocate the sizes correctly if you using the 2.6.x kernel size's are in text files in the /sys folder for that device check see if it maches their.

if not then partition table is wrong make the partition magic boot disk set usually 2 floppy disks then boot from them when asked for second disk don't put disk 2 in press enter while disk 1 is in drive then type at the prompt

PTEDIT if i got file name wrong it is because i not used microsoft for a while so dir on disk 1 to check.
you can reset drive defaults by deleting all numbers throughout the table and save. ptedit will automatically replace all data defaults to zero then partition it with linux.

anyway load it up and it will show the partition table make sure all setting are correct they are in hex then the size in mb far right side column it is easy navigation no mouse though so you got to use keyboard mouse driver is on disk 2.
see if you can sort it like that.

failing that try repartitioning it with ext2 or 3 filesystem in partition magic the redo your steps with new partition. if that dont work then you need a zero fill program or low level format but Warning LAST Option only low level formats can screw up drives can i never yet with low level but it can do there only safe for SCSI drives not ide. try it as last resort only.

darcon3k 07-21-2004 06:53 PM

Using Knoppix 3.4 and running kernel 2.6.6 in /sys/block/hda the size txt files show

dev= 3:0
size=4124736 (This number matches length sectors in qtparted)
stat= 22 0 176 72

I don't see anything about capacity tho

PTEDIT shows Drive1(12966MB) and everything else is zero

So then I booted into Partion magic using 2 floppies and created a 20MB boot partion, 1.5GB swap, and 11.5 root.
Then I ran the clarkconnect installer and diskdruid said the partion table was unreadable and wanted to initalize the disk. After initalizing it shows theres only 2008MB of freespace. So I went back to partion magic and recreated the 3 partions again and then loaded knoppix to see what it would show. I got a "critical error ped_disk_new!" error and then qtparted showed that theres only 2GB again.

Next I used a seagate utility to zero fill the entire harddrive and the problem persists :(

fireicer 07-21-2004 09:12 PM

just for arguments sake try to use a 2.6 kernel distro a new new one like redhat 9 or fedora maybe even mandrake. you could just use a freeBSD distro as that is unix type environ this is just to test it.

by doing this you can find out if the software part in knopix is to blame. it sounds like your knoppix installation or partition program cannot red LBA. you say it supports it in the bios so you get all the correct sizes and allocations so the firmware and disk allocation as per hardware seems ok.

2008MB allocation is a very old type of problem it was due to the mass storage drives being bigger than 1024cylinders if i remember.
on new 30 gig drive the 1024 cylinder would give between 6-8gig for the older drives like 12 gigs this was 2008mb.
dare i say this word but windows NT 3 + 4.0 has this same problem it does not allocate the cylinders correctly for the software to translate.

every time a piece of software calls the disk it relies on the bios to translate the cylinders and dynamically allocate them to the software that is asking for this. if the software does not understand the translation it will always drop back to it's known stable translated size of no more than 1024 cylinders which in your case = 2008mb.

being as it is in the bios go into the bios board utility and make sure that you have the LBA setting correct or if there is a section on the far right of the bios utility page showing your hard disk sectors and cylinder which says block mode set it to auto.

when your system boots look at the list spot showing the disk on the info screen before it boots your disks and check to see if it has allocated block mode.
at the end of the disk size and so forth it will say one of three things:

maybe even Auto

if it says CHS or LARGE then wipe drive completely again go back into bios and change it to LBA then try repartitioning.
failing that then it seems clear to me that knopix does not translate your hardware correctly Via your controller.

To sort this use more up to date distro if same problem you are going to need some sort of driver boot package to lad before you can read the correct disk size.

if you cannot find a driver for this it is unlikely you will if it is built into the motherboard then you need to invest in a offboard controller card.

I recommend/suggest that you use a promise ide/ata card that is compatible to the linux software they all are pritty much but get one stick it into pci slot and the linux PDCpromise driver will translate your disk correctly.

also offbord ide cards tend to take allot of strain of your CPU too so it is a good idea to get one anyway. Just make sure that the card you get is capable for you HDD interface I.e udma33 udma66 ata100 and so on. They come with a driver on the flopy disk aswell as support stated on the side of the box for linux.

darcon3k 07-21-2004 11:40 PM

thx ALOT fireicer, problem solved!

the first part of your post reminded me that I had that same problem a long time ago with this HD when it was in my old pentium. After some digging I found the quick start guide for it and the cylinder limitation jumper was installed on this HD. After I changed the jumper settings to normal master knoppix and clarkconnect both recognize the full capacity.

To anyone else that has this problem in the future with a Maxtor 91360d8 13GB IDE drive heres the jumper settings

(pin layout)
1 2 3 4
5 6 7 8 9

Master 1-5, 2-3
Slave 2-3
Cable Select 2-6

(cylinder limitation mode)
Master 1-5, 3-7
Slave 3-7
Cable Select 2-6, 3-7

fireicer 07-21-2004 11:57 PM

excelent glad you sorted it.

hard disk can be a right pain sometimes so so much to remeber with the mass amount of drives out there.


All times are GMT -5. The time now is 10:32 PM.