-   Linux - Hardware (
-   -   Best Data v.92 serial modem registers as IDE (

RonKZ 03-19-2007 11:23 PM

Best Data v.92 serial modem registers as IDE
New modem, works fine in winXP but I am desparate to escape M$. Using and really like Ubuntu 6.10x64, but...

In Device Manager it's not listed under Serial, nor under 16550, the darn thing shows up as an IDE sub-component ID'd as 56SX-92. But my Device Manager doesn't do anything, just shows the hardware, can't do any moving or fixing or deleting with it.

kppp can sorta find it as ttyS0, enuf to trigger an MR light in the modem but nothing more. Gnome-ppp finds nadda. I am a windoze/dos puter old-timer but am very clumsy with Terminal. This sort of trouble, usually modem, has kept me from transitioning for 3 years now. Can/would someone please help?

GrapefruiTgirl 03-20-2007 12:16 AM

Sh**t..LOL, I had a bunch of info for you here, then my browser crashed :( Grr!
Well, let's see, where was I.. OK, I think that unit has a conexant chipset in it. According to the hardware compatibility list here on LQ, that device gets a 10/10 for compatibility. You will find it as ttys4, according to one of the pages I will post below.
It apparently uses a smartlink driver, which should already be available in Ubuntu for you to use. If the device isn't getting detected (which it actually seems it is) you will need to either modprobe, hotplug, or insmod the driver into the kernel manually. Ubuntu sees it as 56sx-92, so chances are it is being detected.
First, here's the HCL, where the modem gets good reviews:
Here's the linuxant site, where you can get drivers for conexant modems for linux. Save this as a last resort, but if you do end up here, get the modem chipset identifier for Windows, and use it to get the chipset info of the modem before returning there for the driver.
Here's amother hardware forum, where you might learn some more about that modem and Linux:

Now.. If you open a console window and type LSMOD, see if in the list, there is a module that looks like the modem driver, something like smartlink, 56-something, or something that appears to be a modem driver module. If there is something there, or you aren't sure, copy and paste the results into here and post it; we'll try to determine if the mdoem driver is loaded. If not, we'll deal with that situation later.:)
And if it IS there, then is should mainly be a matter of locating the device and using it.
Let us know how you make out, either way.
Good luck! and Welcome to Linux.

GrapefruiTgirl 03-20-2007 12:32 AM

Here's some more useful info, from this thread:
I have the exact same modem as you..and so's worked well with the linspire distro. . Is your modem connected to the COM1 serial port ? If so, at least in have to select /dev/ttyS0 in the modem device field for your modem to work properly. On the installation cd that your modem came with, in the manual on the cd, there are specific instructions how to set up the modem using linux. I hope this helps.

RonKZ 03-20-2007 01:45 AM

oops, not IDE
GrapefruiTgirl, thanks so much

first must admit a blunder - that IDE entry was NOT this modem, it was the name of Best Data CD in that IDE. A real duh! and I apologize to all here and at Ubuntu. For me, that's progress

This modem is supposed to be a controller-based modem, I'm not sure what Conexant should have to do with it, but...

meanwhile I finally fumbled thru scanModem for the nth time but finally did that properly(?) so have a bunch of files to read, but after 3 solid days of this fumbling it'll have to be in the morning. Yes, it found something Conexant but apparently a softmodem also installed in my box, as that's an hsfmodem which I don't care to deal with just now, if ever. Seems that scanModem thing is designed for softmodems, not hardmodems as I think the 56sx92 must be.

So in the morning I'll get back at all this, I am just too tired to think anymore. "I shall return" -- thanx, Ron

GrapefruiTgirl 03-20-2007 06:48 AM

Ron, you're welcome.
LOL, that's funny stuff :) detecting the CD in the drive! Hehe, well no need to apologize; you've learned something which will stay with you ;)
You're correct, your modem IS a controller-based modem, according to what I've read. There are very few manufacturers out there who make modem chipsets; Conexant happens to be one of them, and they supply chips to probably dozens of modem 'manufacturers'; that's what Conexant has to do with it: Your modem might say "Best Data" on it, but it contains a Conexant chipset, which is what the driver is concerned with.
Scanmodem should have produced a file or other output with some data like serial numbers, part numbers, and the like, which you can use to identify the chipset and thus determine which driver you should be using.
Now regarding the softmodem it detected; are you certain you only have the modem, and no others, or do you actually have a softmodem installed as well?? If you are correct, and you may well be, then scanmodem maybe won't detect the serial modem. I can't say for sure, as I've never had an external modem.
Anyhow, your next step should be to check out the documentation on the CD, and see if there is actually Linux instructions in there :) that should simplify things!

RonKZ 03-20-2007 10:29 AM

little progress report
for the time being, I am going to shut down my box and remove the PCI modem within. Reasoning; that's definitely a winmodem which may be a separate project someday in the future, but at this time I don't want to have to sort that out of the scanModem reports. So when I reboot I will do scanModem again. This will be the 3rd time for that, the 1st was a total flop because I didn't find the instructions, the 2nd probably contains info from both modems which adds to the confusion, 3rd time hopefully a charm. So don't bother to reply to this, I'll get back here later today with whatever seems appropriate.

But I feel compelled to comment that these sorts of headaches with Linux are surely the reason that so many newbies (myself included) just give up and return to M$. I've been 3 years now screwing with this off/on, and this time I am determined to succeed, as darnit BG is NOT going to control my puter and my life any more! That has been the last straw for me.

I still have much to do on this, so later... Ron

RonKZ 03-20-2007 07:07 PM

a tad of progress, not there yet
Removing the PCI winmodem (yes, conexant chipset) helped a tad on rebooting, bring the DATA light on, but neither kppp nor gnomeppp could make it work. Among other things, I tried the kppp terminal but couldn't type into in, not that I know much about what to type anyway. refers to an USB modem, mine isn't that, it's serial.

scanModem running for the 3rd time did not find my 56SX92, think that's because it's hunting down win/linmodems, huh?

kppp seems okay with setting ttyS0, but doesn't trigger it dialing; gnomeppp isn't okay with any of ttyS1-4, everything is "no modem found". And yes, I DID disconnect my network & modem on my win-box while messing with this.

My ISP is rather smaller localish, but does have a couple of Linux guys on-staff. Guess that'll be my next move, I did read the thread at LQ which you provided, didn't see much else in there which might help, so guess I'm still stuck. :study:

GrapefruiTgirl 03-20-2007 07:31 PM

OK, can you tell me what the screen returns when you type into a console 'lsmod' ? Copy and paste the results of that command into here. Let's see if the device actually has been detected, and the module/driver has in fact been loaded. If this is the case, the thing to do next is figure out what the command set is for the modem, i.e. what commands might have to be programmed into the kppp in order to make the modem respond. If the module is not loaded in the 'lsmod' list, we'll load it manually, and continue to the next step:
When you open kppp, name your modem; put in your account name and password; put the dialing phone number you use, and set ttys0 as the modem; now on the 'modems' tab, select your modem and click 'edit'; next you should somewhere see a button called "Query Modem" and press it. The result in the little window should be a series of 8 or 10 ATI's or AT's with data after them. It doesn't matter what it says for the moment, but please let me know if you got to this section and if the modem replied.
:) Stick with it; if you want to let me help you ditch Windows, I will!

RonKZ 03-20-2007 08:06 PM

ronkz@gb-server:~$ ismod
bash: ismod: command not found
ronkz@gb-server:~$ Ismod
bash: Ismod: command not found
ronkz@gb-server:~$ lsmod
Module Size Used by
ppp_generic 36384 0
slhc 9856 1 ppp_generic
binfmt_misc 16012 1
rfcomm 51360 0
l2cap 31744 5 rfcomm
bluetooth 64644 4 rfcomm,l2cap
nfsd 301840 13
exportfs 8448 1 nfsd
lockd 84880 2 nfsd
sunrpc 205640 8 nfsd,lockd
radeon 128544 2
drm 105128 3 radeon
cpufreq_userspace 6560 0
cpufreq_stats 9312 0
freq_table 7104 1 cpufreq_stats
cpufreq_powersave 3456 0
cpufreq_ondemand 10928 0
cpufreq_conservative 11272 0
video 22920 0
tc1100_wmi 10632 0
sbs 20928 0
sony_acpi 7704 0
pcc_acpi 19968 0
i2c_ec 7808 1 sbs
hotkey 14536 0
dev_acpi 17540 0
button 9888 0
battery 14088 0
container 6656 0
ac 8328 0
asus_acpi 21924 0
nls_iso8859_1 6912 1
nls_cp437 8704 1
vfat 17920 1
fat 65456 1 vfat
nls_utf8 3840 1
ntfs 109128 1
ipv6 334432 8
af_packet 29452 2
lp 16584 0
snd_intel8x0 42024 1
snd_ac97_codec 127064 1 snd_intel8x0
snd_ac97_bus 4352 1 snd_ac97_codec
sg 44584 0
tsdev 11136 0
usblp 18176 0
i2c_ali1563 9988 0
snd_pcm_oss 57344 0
snd_mixer_oss 22784 1 snd_pcm_oss
snd_pcm 108168 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 31112 1 snd_pcm
i2c_ali1535 9604 0
i2c_ali15x3 10500 0
i2c_core 29312 4 i2c_ec,i2c_ali1563,i2c_ali1535,i2c_ali15x3
parport_pc 43560 1
parport 49932 2 lp,parport_pc
evdev 14592 1
pcspkr 5248 0
8139cp 29696 0
8139too 34816 0
mii 8192 2 8139cp,8139too
snd 79016 8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
psmouse 51088 0
serio_raw 10244 0
floppy 76648 0
soundcore 14112 1 snd
snd_page_alloc 13200 2 snd_intel8x0,snd_pcm
shpchp 49068 0
pci_hotplug 38912 1 shpchp
ext3 164880 1
jbd 74024 1 ext3
ehci_hcd 40456 0
ohci_hcd 25988 0
usbcore 167840 4 usblp,ehci_hcd,ohci_hcd
ide_generic 2944 0
sd_mod 25728 5
sata_uli 10500 4
libata 88984 1 sata_uli
scsi_mod 181424 3 sg,sd_mod,libata
ide_cd 39584 0
cdrom 43816 1 ide_cd
generic 7940 0
alim15x3 15128 0 [permanent]
thermal 19472 0
processor 38280 1 thermal
fan 7432 0
vesafb 11048 0
capability 7304 0
commoncap 10752 1 capability
vga16fb 16656 1
cfbcopyarea 5376 2 vesafb,vga16fb
vgastate 10368 1 vga16fb
cfbimgblt 4352 2 vesafb,vga16fb
cfbfillrect 6272 2 vesafb,vga16fb
fbcon 45824 72
tileblit 4736 1 fbcon
font 10240 1 fbcon
bitblit 8064 1 fbcon
softcursor 3968 1 bitblit

I haven't even read the above as yet, forgive me, first time I have used that anyway. Be aware I ran that while being online from my win-box modem, if that might change the report. ditto for anything following in this post.

quite sure (not absolute) that the modem's on ttys1. kppp - All I get is "modem ready" then "modem initializing", nothing in the log except "expecting OK". Modem Query results all blank, with or w/o "wait for dialtone".

Stick with it; if you want to let me help you ditch Windows, I will! YES YES YES
I need to phone my ISP in the morning, might help with the config here. Have company due soon, so that's all for tonite, folks. thanx again, Ron

GrapefruiTgirl 03-20-2007 08:51 PM

:) No worries.. I think we're in luck, and am checking for some further info from a far more knowledgeable LQ member than I, who has used this modem before successfully.
I am thinking I see the module loaded there in the list, the slhc module..
As for contacting your ISP, you should already have the necessary stuff if you are dialing out using Windoze already, i.e., your email/login, and password.
Anyhow, for the time being, have a great night, and we shall hopefully tackle this in the morning! I think we just need to stick some Hayes commands into it (standard modem commands) and off it'll go.
:) SV

michaelk 03-20-2007 09:23 PM

I believe the slhc module contains routines to compress and uncompress tcp packets for transmission over serial lines and required by required by ppp.

An external serial modem does not require any drivers. scanmodem fails because it is neither a PCI or softmodem device. An external serial modem is the most compatable with linux.

If you computer only has one serial port then the device should be /dev/ttyS0. You can try this command to see of the modem responds.
echo "atdt 555-1212" > /dev/ttyS0

GrapefruiTgirl 03-20-2007 10:44 PM

Awesome, thank you for adding that information, MichaelK :) That may be Just the Thing!!
And so, providing the modem does respond, then it is a matter of sticking in the right commands/command set, and all should be well?

michaelk 03-20-2007 10:57 PM

Yes all should be well

RonKZ 03-21-2007 10:39 AM

thanks for joining in here, michaelk, and for all your great efforts, GrapefruitTgirl. I'm feeling somehow we will get there today, would that be super super!

gnomeppp, set either ttys0 or ttys1 returns:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.56
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATX3
--> Sending: ATQ0
--> Re-Sending: ATX3
--> Modem not responding.

using Terminal (is that the correct tool to use?):
echo "atdt 555-1212" > /dev/ttyS0 or
echo "atdt 555-1212" > /dev/ttyS1
returns nothing

lights on 56SX92 modem show PWR and DATA, all the time, never noticed any change.

next will call my ISP (, supposed to be a couple of linux guys there including the owner

RonKZ 03-21-2007 12:25 PM

wvdial says it can't open /dev/modem no such file/directory.
I've not yet phoned my ISP, but the above should tell us something major??

All times are GMT -5. The time now is 07:35 PM.