-   Linux - Hardware (
-   -   Belkin KDM & MS scoll mouse solution (jumping mouse) (

otchie1 07-26-2004 07:44 PM

Belkin KDM & MS scoll mouse solution (jumping mouse)
I've stumbled on a solution to the jumping mouse problem experienced by users of Belkins KDM when switching back to linux from any other box. The mouse would go all random on you and make a mess of your desktop. I've seen the problem discussed in several forums and even read about one user taking it to Belkin without getting much joy.

I fell on this configuration by accident and it works, enabling the scroll wheel and letting you switch between boxes without losing your mouse. This is for the PS2 MS optical scroll mouse job through the Belkin omniView E series switch. Actually it's a USB mouse with a USB->PS2 converter

Make the following changes to your xorg.conf (or equivalent file);

in Server Flags put

Option "AllowOpenMouseFail" "true"

in the mouse device section use,

Identifier "YOUR IDENTIFIER" #keep it the same as yours or nothing will work
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5" #the space is important..thx Shillo
Option "Device" "/dev/psaux"
Option "Emulate3Button" "true"
Option "Emulate3Timeout" "true"
Option "SendCoreErrors" "true"

That's it.
When you restart X you can switch boxes to your heart's content with no grief. In my setup there is a brief delay of 2 seconds or so before the mouse is recognised on the new box but even windows does that :-) Just sit there patiently

ChrisDodd 03-01-2006 08:45 PM

I've tried the above with a Gentoo system, and it doesn't seem to help. Anyone have any better ideas? Looking at the raw data coming from the mouse, it seems totally scrambled after the KVM switches, almost like its trying to read serial data at the wrong baud rate or something. Older windows systems (Nt4.0) seem to sometimes have the same problem as Linux, but switching screens will eventually reset something so that it works -- but that never seems to help in the Linux case

otchie1 03-02-2006 01:16 PM

The only other thing I can recommend is to change the KVM. DLink works flawlessly. It is a problem with how Belkin deal with faking mouse presence on all mouse ports.

It's also worth checking on the date of the last post in a thread :-)

All times are GMT -5. The time now is 09:14 AM.