LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-05-2003, 10:28 AM   #1
crabfish
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
Bad hdparm with nforce


Hi

Been using gentoo for a while now and mostly all works fine.
However my hds performance isn't too good.


I've got:
Maxtor 80gb 8mb buffer
A7N8X nforce2 mobo


root@datorjavel root # hdparm -tT /dev/hda

/dev/hda:
Timing buffer-cache reads: 128 MB in 0.53 seconds =243.81 MB/sec
Timing buffered disk reads: 64 MB in 36.92 seconds = 1.73 MB/sec

root@datorjavel root # hdparm -i /dev/hda

/dev/hda:

Model=Maxtor 6Y080P0, FwRev=YAR41BW0, SerialNo=Y3HSJFSE
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=160086528
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma6
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: (null): 1 2 3 4 5 6 7


Using kernel 2.4.20-gentoo-r6

it seems as the nforce chipset isn recognised or something even tough I
belive I've compiled it right.


ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller on PCI bus 00 dev 48
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
AMD_IDE: Bios didn't set cable bits corectly. Enabling workaround.
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD_IDE: PCI device 10de:0065 (nVidia Corporation) (rev a2) UDMA100 controller on pci00:09.0
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdcMA, hddMA
hda: Maxtor 6Y080P0, ATA DISK drive



Any idea cause this makes me want to switch to win again
 
Old 09-05-2003, 10:55 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
What are your settings? Did you turn dma on?
Code:
 root@uilleann # hdparm /dev/hda

/dev/hda:
 multcount    = 16 (on)
 I/O support  =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr       =  0 (off)
 readonly     =  0 (off)
 readahead    =  8 (on)
 geometry     = 4865/255/63, sectors = 78165360, start = 0
 busstate     =  1 (on)
root@uilleann # hdparm -tT /dev/hd{a,a,a}

/dev/hda:
 Timing buffer-cache reads:   128 MB in  0.90 seconds =142.22 MB/sec
 Timing buffered disk reads:  64 MB in  1.39 seconds = 46.04 MB/sec

/dev/hda:
 Timing buffer-cache reads:   128 MB in  0.90 seconds =142.22 MB/sec
 Timing buffered disk reads:  64 MB in  1.38 seconds = 46.38 MB/sec

/dev/hda:
 Timing buffer-cache reads:   128 MB in  0.91 seconds =140.66 MB/sec
 Timing buffered disk reads:  64 MB in  1.39 seconds = 46.04 MB/sec
# Hard drive tweak
Speeding up Linux Using hdparm
Not mentioned in the article:
UDMA 33/66/100. Add the -X option, and then this number i.e. (-X 69)
-X 33 ====> Multiword DMA
-X 66 ====> ATA-33 (UDMA2)
-X 68 ====> ATA-66 (UDMA4)
-X 69 ====> ATA-100 (UDMA 5)
 
Old 09-05-2003, 10:57 AM   #3
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
my DMA mode won't work (edit: automatically, that is) with nf2 under slack, either, even with all the DMA options selected in the kernel. i had to put the hdparm commands in /etc/rc.d/rc.local. i actually prefer it that way now, b/c i can see hdparm being turned on for each drive right before login at each boot.

Last edited by synaptical; 09-05-2003 at 11:00 AM.
 
Old 09-05-2003, 11:21 AM   #4
crabfish
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Oops forgot that


root@datorjavel alexander # hdparm /dev/hda

/dev/hda:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 9964/255/63, sectors = 160086528, start = 0


as you can se DMA is on ?????
 
Old 09-05-2003, 11:33 AM   #5
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Can you see any difference turning dma on and off?
 
Old 09-05-2003, 11:39 AM   #6
crabfish
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Turning DMA off

root@datorjavel alexander # hdparm -d0 /dev/hda

/dev/hda:
setting using_dma to 0 (off)
using_dma = 0 (off)
root@datorjavel alexander # hdparm -tT /dev/hda

/dev/hda:
Timing buffer-cache reads: 128 MB in 0.40 seconds =320.00 MB/sec
Timing buffered disk reads: 64 MB in 35.51 seconds = 1.80 MB/sec

even worse than before
 
Old 09-05-2003, 12:13 PM   #7
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
This is strange - I got a nforce2 board with a maxtor and that gives me something like this:
bash-2.05b# hdparm /dev/hdb

/dev/hdb:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4998/255/63, sectors = 80293248, start = 0
bash-2.05b# hdparm -Tt /dev/hdb

/dev/hdb:
Timing buffer-cache reads: 1740 MB in 2.00 seconds = 870.00 MB/sec
Timing buffered disk reads: 128 MB in 3.01 seconds = 42.55 MB/sec
The strange thing is that the cache reads are double of the ones you get.Did try with the same settings you got but that didn't change a lot.
I use the ck-sources kernel but with gentoo-sources it was the same.
You might want to check if something is setup wrong in the bios.
 
Old 09-05-2003, 12:29 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
here's what i get with nforce2 and maxtor 40GB, so maybe it is your BIOS settings. not sure this would matter for DMA, but are you using ATA100/133 IDE cables?

bash-2.05b# hdparm /dev/hdb

/dev/hdb:
multcount = 16 (on)
IO_support = 3 (32-bit w/sync)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4998/255/63, sectors = 80293248, start = 0
bash-2.05b# hdparm -Tt /dev/hdb

/dev/hdb:
Timing buffer-cache reads: 128 MB in 0.22 seconds =581.82 MB/sec
Timing buffered disk reads: 64 MB in 1.30 seconds = 49.23 MB/sec
 
Old 09-05-2003, 01:06 PM   #9
crabfish
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
cables??
im using the cables wich came with the motherboard

Last edited by crabfish; 09-05-2003 at 01:19 PM.
 
Old 02-07-2004, 10:13 PM   #10
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
I am definitely using 80pin cables (modware i think...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM
nforce-net and nforce-audio not working on gentoo bling bling Linux - Hardware 2 12-16-2003 06:11 PM
hdparm -g NOT= hdparm -i ---LILO hangs @ L stevewalsh Linux - General 4 07-23-2001 09:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration