-   Linux - Hardware (
-   -   auto mount problem and fstab (

Mogli 09-18-2008 04:04 AM

auto mount problem and fstab
Hi I recently installed Fedora-9 in my SONY VAIO laptop. /etc/fstab content is as follows:

UUID=b15cf2a1-1ad8-447a-871b-8ceddcc6f59d / ext3 defaults 1 1
UUID=3df71cdc-42f0-4d87-bd0d-6c08737bd0c7 /home ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=acb66d68-9e75-446b-b6ce-ab4b024500e7 swap swap defaults 0 0

Here my problem is, I have two 'ntfs' drives. fedora detecting both drives as 'New Volume' but it is not able to mount at start up. Every time need to mount manually as a root user. In the same system I have windows XP, it detecting these two drives with D and E names.

Please suggest me how to rectify this problem.

Thanks in advance

Nylex 09-18-2008 04:29 AM

Have you already tried adding fstab entries for those partitions? If so, did it not work? In that case, please post the relevant entries. If you haven't already added entries, then do so..

farslayer 09-18-2008 11:35 AM

You should be using ntfs-3g to mount ntfs partitions read write.

ntfs-3g /dev/sda2 /mnt/winstorage -o umask=0,nls=utf8

If that all works you can add it to your /etc/fstab file so it will automatically mount

/dev/sda2 /mnt/winstorage ntfs-3g umask=0,nls=utf8 0 0

man ntfs-3g for more information

Mogli 09-19-2008 04:13 AM

This problem solved.

Thanks for helping.

All times are GMT -5. The time now is 12:55 PM.