LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-04-2004, 05:41 PM   #1
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 31
audio device fails to open on arch linux, even after alsa config


i've been having trouble setting up sound under arch linux. i know my sound device will work under linux, because i've had it working under many other distros.

i followed these directions in the arch wiki word-for-word: http://wiki.archlinux.org/index.php/Alsa%20setup

under slackware, a simple "alsaconf" worked for me. arch was sort of promising when i got weird feedback from the speakers by boosting mic volume in alsamixer. but still no sound anywhere - xmms fails to open an audio device, other programs don't work, even though i see alsa start up successfully at boot, and i know it's running.

i have integrated CMedia 9739A audio. i'm using the "snd-via82xx" sound module because it worked under slack.

edit: by the way, i get the same errors when logged in as root, so it has nothing to do with allowing regular user access to the sound device.

also, it seems to be looking for /dev/dsp, which doesn't exist. am i supposed to point it to the correct location? and if yes, how?

Last edited by sether; 10-04-2004 at 05:48 PM.
 
Old 10-07-2004, 12:43 AM   #2
sether
Member
 
Registered: Aug 2004
Posts: 695

Original Poster
Rep: Reputation: 31
wow, more than 2 days passed with no responses.

anyways, i got the solution finally from the people on the arch linux forums. if anyone needs the solution: http://bbs.archlinux.org/viewtopic.p...248&highlight=
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot open audio device deus_machinarum SUSE / openSUSE 8 06-20-2005 04:44 PM
Stuck at grub config for Arch Linux DeadPenguin Linux - Newbie 1 11-14-2004 01:34 AM
MythMusic fails to open ALSA:default jpbarto Linux - Software 1 09-19-2004 11:22 AM
[Audio] Cant open device (permissions) seb3579 Linux - Hardware 3 05-14-2004 11:24 PM
ogg123 can't open audio device oot Linux - Newbie 2 05-21-2003 05:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration