-   Linux - Hardware (
-   -   ATI reconfigure = no X (

wyth 02-26-2007 10:24 PM

ATI reconfigure = no X
I'm pretty sure there's an easy answer to this that I'm just not finding, so I'm posting for some aid.

Earlier I tried installing beryl on Kubuntu with the automatic script here. Didn't work. So I tried to remove beryl. I'm not even certain my donkey of a machine can run it. But when I did remove it, I couldn't get X windows again. It would always boot to a tty1 screen.

Did a dpkg-reconfigrere xserver-xorg, and when I chose ati, I can get back in. But when I try to configure the fglrx drivers, I end up back at the tty1 screen. (sudo aticonfig --initial, sudo aticonfig --overlay-type=Xv; did do sudo depmod -a, did disable Composite in xorg.conf.)

- lspci -n | grep 0300 gets me 01:00.0 0300: 1002:4c66 (rev 01)
- lspci | grep VGA gets me 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)
- kernel is 2.6.17-11-generic

I can offer any more info as needed. There has to be an answer to this; when I configure the ATI drivers, I lose X. This never happened until I removed Beryl. If I have to go back to beryl, that's fine, because it wasn't running anyway. But at least I had my nice desktop that didn't degrade. What do I need to reconfigure/fix so I can have X back and video card drivers that work? These fuzzy screens are getting on my nerves.

Help anyone?

wyth 02-27-2007 01:13 PM

Bumping this, cuz I need to get this fixed. Been a problem for a couple days now.

wyth 03-03-2007 10:24 AM

Ach, no reply.

No matter.

I'm not quite sure how it happened, but this thing has sorted itself out. All's I can say is that eventually I had an update with a new ATI driver and a new xorg, and after that I gave the standard ATI configuration another try. This time it took. For the first time in a work week I have a properly-working X Windows system.

But I'm still interested in Beryl...

All times are GMT -5. The time now is 01:36 PM.