LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-03-2006, 09:07 PM   #1
TheOddLinguist
LQ Newbie
 
Registered: Dec 2004
Location: Larksville, PA, USA
Distribution: Mandrakelinux
Posts: 5

Rep: Reputation: 0
ATI Radeon Troubles, of course


Hey, everyone.

I just bought a new hard drive and decided to install SUSE 10.1 on it for my dual-boot system. The last time I tried running this dual-boot, I had some trouble, but I thought it was the bad hard drive. Since this is a new one and the problems are back, I've narrowed it down to the video card.

It's an ATI Radeon 9250 PCI. I've read all the troubles others have had, and I've tried most everything that worked for everyone else. But I still can't get it working.

The thing is...it is technically working. I mean...I'm using it now. But, if I go to change a graphics card setting in YaST...or try to run certain programs that change the video mode...the screen goes black...and the only way to fix it is to reboot.

So, I ran fglrxinfo:
[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI

...the list goes on and on.

I've read that some reverted their libGL.so.1.2 to an older version and it worked...I tried it...didn't work for me. So, others ran SaX2. If I do that, the screen goes black...I reboot...and I run fglrxinfo again.

But, this time it mentions Mesa instead of ATI. Some said that running aticonfig instead of SaX will fix this...so I did...and the entrypoint error starts all over again.

Anybody have any ideas on what I can do? hehe I'm in a Catch-22 here...and no way of getting out in sight. If you need more information, let me know. But, I'd really like to get this working. I love SUSE, but if I can't get this fixed, I'll have to come up with some other use for this hard drive...hehe

Thanks in advance...


Sincerely,
Christopher David YUDICHAK
 
Old 06-04-2006, 03:29 AM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Check out the DRI link in my sig. It has an extensive ATI section
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI drivers fakes- Impossible to run 3D on ATI Radeon 9550 ilpadrino Linux - Hardware 29 06-24-2006 02:59 PM
ATi Radeon 9000 Pro and Radeon(flgrx) driver included on Mandrake 10.1 Official St3althcAt Linux - Hardware 1 05-07-2005 09:30 PM
hello a new in linux and i got a big problem with my ati radeon 7000/radeon ve card AKAKAK Linux - Hardware 0 01-19-2005 10:39 AM
Troubles with ATI Radeon 9800 Pro Nychold Linux - Hardware 4 07-04-2004 12:44 PM
redhat 8 and ATI Radeon agp 320m (aka Radeon Mobility U1) nelsonnery Linux - Hardware 11 11-06-2003 07:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration