-   Linux - Hardware (
-   -   ATI Radeon Drivers & MesaGL problem (

elbozo 07-22-2003 10:53 PM

ATI Radeon Drivers & MesaGL problem
Hi all,

OK, after some kernel rebuiling i get X to load using fglrx ,
problem is i can't figure out why games ( q3 ) and fglrxinfo
keep saying that the vendor of my /usr/lib/X11R6/lib/
is Mesa... I have removed the MEsa RPMs with --nodeps and
installed the ati driver package. I followed all symlink to a that
libabry files and deleted that lib, and reinstalled the ati drivers.
i started quake3 with a -set r_gldriver /usr/lib/X11R6/lib/
but it still said:

GL_VENDOR: VA Linux Systems, Inc.
GL_RENDERER: Mesa GLX Indirect
GL_VERSION: 1.2 Mesa 3.4.2

basicaly the same thing fglrxinfo says... I need help !

ati 9700pro
redhat-8.0 / kernel 2.4.20

wazungy 09-25-2003 05:51 PM

I am having the same problem.
I just spent well over 12 hours in 2 shifts trying to get the ati drivers working under xfree4.3.
Partial success.
modprobe -v fglrx now gives some info, but fglrxinfo states I am using Mesa and not the FireGL.

Using radeon 9500 pro...
Mesa Gears (OpenGL toy) crawls along when compared to a system using an old matrox G400.

Let me know if you get any further with your problem.

A7V8x. Radeon 9500 pro. Mandrake 9.1.

marto 10-02-2003 01:50 PM

Hi guys.

I got the same problem but solved this thanks to 'jbparto'; the solution is in the thread:

I run Mandrake 9.1 with ATI Radeon 9500 Pro and a VIA KT400 chipset. That worked just fine. Try it.

All times are GMT -5. The time now is 07:17 PM.