LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ATI Radeon 9800/Pro + SuSE 9.0 (freezes after successfull DRI load) (https://www.linuxquestions.org/questions/linux-hardware-18/ati-radeon-9800-pro-suse-9-0-freezes-after-successfull-dri-load-124357/)

Euphorix 12-09-2003 05:36 PM

ATI Radeon 9800/Pro + SuSE 9.0 (freezes after successfull DRI load)
 
I have read the posts on these forums as well as many others and have come so close to fixing this on my computer. But in the end, it doesnt work! I dont understand how there is not more complaint about this issue for such a popular video card. Most people i know use ATI Radeon 9800 or nVidia GeForce cards.

Anyhow, I have a ASUS A7N8X Deluxe Motherboard, it has a nForce2 chipset. I do have the AGPGART module loaded in a SuSE Linux 9.0 clean install. I have made the kernel modules for the drivers and the FGLRX module loads fine. The module was obtained from the SuSE website's RPMs (fglrx.rpm + km_fglrx.rpm) And the configuration file XF86Config-4 was created using the xfglrxconfig tool.

If the AGPGART doesnt get a hold and DRI fails to load, I get 2D acceleration (this i can do by unloading the fglrx module) So i can use my system, but cannot use 3D acceleration while fglrx is not loaded (obviously) As soon as everything is loaded including AGP and Video card drivers, X goes through loading DRI fine and then freezes the whole system :(

== From /var/log/XFree86.0.log ==

II) fglrx(0): detected XFree86 version: 4.3.0
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmGetBusid returned ''
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:3:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xe48f5000
(II) fglrx(0): [drm] mapped SAREA 0xe48f5000 to 0x40022000
(II) fglrx(0): [drm] framebuffer handle = 0xd0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 3.2.8
(II) fglrx(0): Date: Sep 21 2003
(II) fglrx(0): Desc: ATI Fire GL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.4.21-99-athlon
(II) fglrx(0): Build-Kernel MODVERSIONS: yes
(II) fglrx(0): Build-Kernel __SMP__: no
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0xe3000000
(II) fglrx(0): [agp] Mode=0x1f00421f bridge: 0x10de/0x01e0
(II) fglrx(0): [agp] AGP disable mask 0x00000000
(II) fglrx(0): [agp] enabling AGP with mode=0x1f00431c
(II) fglrx(0): [agp] AGP protocoll is enabled for grafics board. (cmd=0x1f004310)
(II) fglrx(0): [agp] grafics chipset has AGP v3.0 (native mode)
(II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 28672
(II) fglrx(0): [drm] texture shared area handle = 0xecd95000
(II) fglrx(0): VisualConfigs initialized
(II) fglrx(0): DRI initialization successfull!
(II) fglrx(0): FBADPhys: 0xd0000000 FBMappedSize: 0x00700000

== End Log ==

The DRI layer loads correctly and the as X changes from text mode to graphics mode, it freezes to a black screen.

*** SYSTEM FREEZES HERE *** Note: I cannot switch to console, i cannot do anyhting in this black screen state. The only thing I can produce is a beep if i hold ctl-alt-del, but no reboot takes place and no hard disk activity during this whole time.

Any help in resolving this problem would be greatly appreciated! This was a very expensive card for me, and my migration to Linux from windows has been a fun one so far, but this sure is a downer. Kinda dissapointing on ATI and SuSE's behalf.

sirra462 12-09-2003 07:01 PM

I assume that you have read my post here
A good place to look for specific questions is the rage 3D linux forum
Also see some good threads about DRI. I wish that I could help, but this seems a little beyond me at the moment. My only advice would be to go through my thread again, and don't install the Nvidia Nforce2 modules first, but last. I did the same thing and it worked only when installed last.

Euphorix 12-09-2003 07:25 PM

Yes of course i have gone through all your material. I have gone through and tried from a clean install several times.

I see the problem with AGP not loading in SuSE 9.0 so you have to add it thats fine. (i've even tried adding it to the kernel instead of a module) I have also tried to remove the XFree86 DRI Manager, it doesnt make a difference.

I have gone through everything, and I have in fact gotten DRI to load and AGP to load. In the end, it freezes to a black screen anyways.

I think there is still a lot of work to be done in the world of linux, everything is always half-done. its quite frustrating. I've migrated back to windowsXP until Linux aquires the proper drivers for the latest hardware.

thanks for your time.

sirra462 12-09-2003 07:43 PM

Don't give up! You are dealing with new hardware and a non-standard OS. Linux needs people like us who are on the cutting edge of hardware. If you choose to abandon it now, that enthusiast edge will lose out an linux will remain the midrange OS that it is today. The whole beauty of the OS is that it is open, and anyone willing to contribute to it can.
Besides ATI released a video card to function under directX 9, and we are trying to use it with an operating system that it was not designed for.
Gaming in linux is no walk in the park and requires a lot of tedious work to get things to work correctly, and when it finally is working correctly, it isn't any better than it would have been in Windows. This is not linuxs' fault, this is the fault of the consumer who chooses the easy way out (granted I enjoy easy to use products as much as the next guy). Until there is a high enough demand for linux-based hardware (imagine that day when some piece of hardware won't work in Windows and the users of that system will want a linux emulator, call it linex :) ) we will always have to deal with these problems. So use 2D acceleration and leave 3D for windows at the moment. ATI may release new drivers that are way better than the ones that we use today.

By the way these drivers that they gave us are for the high end 3D development teams that are using programs like Maya and Solid Designer. Notice that it is for the fireGL based boards and not Radeon based. The only reason they get these drivers is because the spend hundreds of thousands each year to use ATI cutting edge technology and they demand support for their *nix workstations. We are lucky that we are receiving them.

So don't get too upset by the lack of support, I know that it sucks but it is the best we have at the moment. No one complains that the Radeon 9800 Pro isn't compatible with OS-X, because that would be silly. Hang in there, and your wishes will come true.

crodrigu1 10-02-2006 10:32 AM

is software/hardware problem
 
I have the same issue (system freezes) what I found is that mtr registers are modified, then the ATI drivers throws a oops (with interrupts disabled!)


All times are GMT -5. The time now is 08:05 PM.