-   Linux - Hardware (
-   -   ATI Mobility Radeon on OpenSuse 11.4 fglrx/driver issue (

Tekth 05-18-2011 01:59 AM

ATI Mobility Radeon on OpenSuse 11.4 fglrx/driver issue
Im attempting to get my ATI Mobility Radeon 3650 HD to function properly on an new installation of OpenSuse 11.4. This is on a Toshiba A300 laptop.

I have been trying for a couple of days now and cant seem to figure out how to get this to work. I have tried:

1) booting with nomodeset
2) installing the new catalyst 11.5 software from ATI, released a couple of days ago
3) booting in failsafe
4) editing 50-device.conf and uncommented the "Driver "radeon"" line

Everytime I boot, irregardless of what boot options I use, FGLRX module does not load. System tells me that its attempting to create/load it only to fail everytime.

I have seemed to get it to install only to have glxgears and glxinfo fail on me still.

linux-psf8:/home/tokth # glxgears
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 137 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stream: 15

I will be honest.. I have no idea where to look anymore and everything I seem to find on the internet about the issue are scenarios that I have already tried. Any help is greatly appreciated.

adamk75 05-18-2011 05:20 AM

Please show us your /var/log/Xorg.0.log file.

EDIT: And the output of "dmesg | egrep 'drm|fglrx' "

Tekth 05-18-2011 12:51 PM

Xorg.0.log -

output of dmesg | egrep 'drm|fglrx':

linux-psf8:/home/tokth # dmesg | egrep 'drm|fglrx'
linux-psf8:/home/tokth #

adamk75 05-18-2011 01:00 PM

Looks like you don't have the fglrx kernel module installed. What's the output of 'find /lib/modules/`uname -r`/ -iname fglrx.ko '?


Tekth 05-18-2011 01:10 PM

It returns nothing. I have installed it via yast... or at least I thought I did. What I do notice is that in boot, fglrx's creation is attemtped since it is missing, but fails and then bootup just continues on. This is with nomodeset OR failsafe.

adamk75 05-18-2011 01:15 PM

Well you'll need to find out why the installation didn't build the kernel module. I'm not very familiar with openSUSE, but I know many distributions have separate packages, one for the fglrx userland and one for the fglrx kernel module. That's the first thing I'd check.


Tekth 05-18-2011 06:07 PM

I have no idea how to figure that out. So I just reinstalled on my laptop and then followed the instructions found here:

my card is now working properly.

All times are GMT -5. The time now is 06:58 AM.