Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 10-11-2009, 02:34 PM   #1
LQ Newbie
Registered: Jan 2007
Posts: 4

Rep: Reputation: 0
ATI fglrx driver expands screen size

I have notebook ASUS A8Sr with ATI HD2400 video card (monitor of notebook has size 1280x800). And Linux Slackware64 13.0 with kernel (x86_64 smp) updated from Slamd64.
After I installed newest ATI fglrx driver (version 9.9). All things work. But screen size (virtual screen of course) become more large - 2560x800 - in two times. And first part (x=0..1280) as a normal screen, but second part (with x=1281..2560) like black hole - black color with invisible desktop items.

myhost:$ xrandr
Screen 0: minimum 320 x 200, current 2560 x 800, maximum 2560 x 800
default connected 1280x800+0+0 0mm x 0mm
   2560x800       60.0  
   1280x800       60.0* 
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.0  
   720x480        60.0  
   640x480        60.0  
   640x432        60.0  
   640x400        60.0  
   512x384        60.0  
   400x300        60.0  
   320x240        60.0  
   320x200        60.0
I note that selected "1280x800" mode in this list, but in head write "current 2560 x 800"

I have not any virtual screen in xorg.conf, but have option "PreferredMode"
Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1280x800"

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Modes   "1280x800"
I try setting option "Virtual 1280 800" but not work.

It is part of Xorg.0.log
(II) LoadModule: "fglrx"
(II) Loading /usr/lib64/xorg/modules/drivers//
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for, module version = 8.65.4
        Module class: X.Org Video Driver

(--) Chipset Supported AMD Graphics Processor (0x94C9) found

(**) fglrx(0): Center Mode is disabled 
(==) fglrx(0): TMDS coherent mode is enabled 
(II) fglrx(0): Total of 13 modes found for primary display.
(--) fglrx(0): Virtual size is 1280x800 (pitch 0)

(--) fglrx(0): Display dimensions: (300, 190) mm
(--) fglrx(0): DPI set to (108, 106)
(--) fglrx(0): Virtual size is 2560x800 (pitch 2560)

(WW) fglrx(0): Option "PreferredMode" is not used   
(WW) fglrx(0): Option "VendorName" is not used      
(WW) fglrx(0): Option "ModelName" is not used       

(II) fglrx(0): Restoring recent mode: 1280x800@60Hz
Whole log file in attach.

This is problem with fglrx driver only. Radeon driver work fine.

How I can remove virtual screen "2560x800"?
Attached Files
File Type: txt Xorg0log.txt (39.2 KB, 6 views)

Last edited by Pakhomov; 10-11-2009 at 02:42 PM.
Old 10-11-2009, 05:00 PM   #2
Senior Member
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 3,031

Rep: Reputation: 539Reputation: 539Reputation: 539Reputation: 539Reputation: 539Reputation: 539
Take this and copy and paste it into xorg.conf, in subsection display, underneath Mode:

Modeline "1280x800"x60.0 68.94 1280 1292 1356 1408 800 803 806 816 +hsync +vsync

You can also shut down X, and run:

X -configure

from a terminal. The command will give you instructions. If the new xorg.conf works, you will get a textured background when you test it with:

X -config /home/sam/

The new xorg.conf will be more complete, and you can then add what you need from the existing xorg.conf. But adding the modeline to the existing xorg.conf will probably work. Try it first.
Old 10-12-2009, 09:01 AM   #3
Senior Member
Registered: Feb 2003
Distribution: debian
Posts: 3,258
Blog Entries: 1

Rep: Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681
You might try adding that parameter for virtual screen at the resolution you want to use. 1280x800. Or wait six months for the next update and it'll fix itself? ATI drivers are.... frustrating.

        SubSection "Display"
                Depth   24
                Virtual "1280x800"
                Modes   "1280x800"
Or run ati-config against your current xorg.conf and see if it knows how to fix itself. Or a fresh xorg.conf "X -configure" and ati-config against that.

Taking a second look at your conf, you're missing the Depth argument for your Modes. Just adding that might help, or might otherwise be the issue. Virtual is a bit redundant. Although isn't it supposed to not use/do virtual if you don't specify it?


ati, driver, fglrx, screen, virtual

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI driver, fglrx - FATAL: Error inserting fglrx hubabuba Slackware 4 04-18-2009 01:27 PM
Gnome 2.20 - fglrx - multi head - screen size issues rhoekstra Linux - Desktop 0 10-12-2007 04:05 PM
ATI fglrx - black screen rokstar_IT Linux - Hardware 1 09-17-2006 05:08 AM
ati FGLRX driver white screen with 9700M on FC5 rajmund Linux - Laptop and Netbook 1 08-22-2006 05:36 AM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 01:10 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:05 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration