-   Linux - Hardware (
-   -   ATI drivers installed..but not?? (

squishywalrus 11-29-2005 01:38 PM

ATI drivers installed..but not??
Alright, I'm running Fedora Core 4 x86-64 and installed the ATI fgrlx drivers for my X800 pro as instruced here: (won't let me post URL's)

My first problem was I couldnt run UT2k4 because I got this error:

linux:/usr/games/ut2004 # ./ut2004
WARNING: ALC_EXT_capture is subject to change!
Couldn't set video mode: Couldn't find matching GLX visual


Exiting due to error

Then, I ran fgrlxinfo and got this:

display: :0.0  screen: 0
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Oh, and it should have the Mesa website after "Mesa project:" but I can't post the URL.

I tried following the install instructions again, but yum tells me it has nothing to do.
Anyone have any ideas?

crazylincoln 11-29-2005 10:35 PM

When I installed my ATI drivers, under the same enviroment, the fglrx kernel module could not install because it was looking for ioctrl32.h in the wrong place, so I copied it over to to where it was looking for it and recompiled.
So check and make sure the kernel module compiles and loads

Hopes this helps!

43r05p4c3 12-02-2005 02:00 PM

Failed ATI driver installations are fairly common. A simple search of the forums should some helpful results, like these:
ATI in FC 4
More ATI in FC 4 (64 bit)
Also, when installing mine, I came across a number of articles addressing issues with 64 bit processors, such as this one.
64-bit ATI successful installation

Those links ought to help. And if it takes a while to get the drivers working, don't feel bad (I took about 6 months to get it working--although I also learned everything I've learned about linux in that time and addressed sound problems and..... well you get the idea)


[EDIT]... I just realized that the second link I included is more recent than the third one, and is probably more appropriate for the drivers you're using.[/EDIT]

All times are GMT -5. The time now is 07:17 PM.